summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-04-13 18:14:04 +0200
committerSam James <sam@gentoo.org>2024-04-13 18:35:37 +0100
commit2983664d141cbf6ccd9f6e54d83aacbe5eccacb8 (patch)
tree8513536dd527eef257fc46ea84d12e16cc4d46af /media-gfx
parentmedia-fonts/iosevka: add 29.2.0 (diff)
downloadgentoo-2983664d141cbf6ccd9f6e54d83aacbe5eccacb8.tar.gz
gentoo-2983664d141cbf6ccd9f6e54d83aacbe5eccacb8.tar.bz2
gentoo-2983664d141cbf6ccd9f6e54d83aacbe5eccacb8.zip
media-gfx/openvdb: 11.0.0 fix abi-compat USE
The values for `-DOPENVDB_USE_*_ABI` are derived from the initial value of `version`. By changing the value of `version` depending on the abi*-compat USE-flag they are instead derived from the modified value for any USE="!abi11-compat". That results in `usex abi*-compat`-queries on values outside of the supported +1/-2 range. Closes: https://bugs.gentoo.org/929926 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36239 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/openvdb/openvdb-11.0.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-gfx/openvdb/openvdb-11.0.0.ebuild b/media-gfx/openvdb/openvdb-11.0.0.ebuild
index 35a71fe06c64..ff01eb449a31 100644
--- a/media-gfx/openvdb/openvdb-11.0.0.ebuild
+++ b/media-gfx/openvdb/openvdb-11.0.0.ebuild
@@ -175,21 +175,22 @@ src_prepare() {
}
my_src_configure() {
- local version
+ local version abi_version
version=$(ver_cut 1)
+ abi_version="${version}"
if use "abi$(( version + 1 ))-compat"; then
- version=$(( version + 1 ))
+ abi_version=$(( version + 1 ))
elif use "abi$(( version - 1 ))-compat"; then
- version=$(( version - 1 ))
+ abi_version=$(( version - 1 ))
elif use "abi$(( version - 2 ))-compat"; then
- version=$(( version - 2 ))
+ abi_version=$(( version - 2 ))
fi
local mycmakeargs=(
-DCMAKE_FIND_PACKAGE_PREFER_CONFIG="yes"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
+ -DOPENVDB_ABI_VERSION_NUMBER="${abi_version}"
-DOPENVDB_BUILD_DOCS="$(usex doc)"
-DOPENVDB_BUILD_UNITTESTS="$(usex test)"
-DOPENVDB_BUILD_VDB_LOD="$(usex utils)"