summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-02 07:14:39 +0100
committerSam James <sam@gentoo.org>2024-09-02 07:15:19 +0100
commit8182367d383e8e8175094e8634f8193fdde8ace0 (patch)
tree74b31de5deb1884a37e9dba13cdbd389b54f04aa /media-gfx
parentdev-util/diffoscope: add 277 (diff)
downloadgentoo-8182367d383e8e8175094e8634f8193fdde8ace0.tar.gz
gentoo-8182367d383e8e8175094e8634f8193fdde8ace0.tar.bz2
gentoo-8182367d383e8e8175094e8634f8193fdde8ace0.zip
media-gfx/graphicsmagick: add 1.3.45
PS support is gone upstream. Closes: https://bugs.gentoo.org/930545 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphicsmagick/Manifest2
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.45.ebuild160
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-9999.ebuild8
-rw-r--r--media-gfx/graphicsmagick/metadata.xml1
4 files changed, 167 insertions, 4 deletions
diff --git a/media-gfx/graphicsmagick/Manifest b/media-gfx/graphicsmagick/Manifest
index 064922e59397..9706fab4aa29 100644
--- a/media-gfx/graphicsmagick/Manifest
+++ b/media-gfx/graphicsmagick/Manifest
@@ -2,3 +2,5 @@ DIST GraphicsMagick-1.3.42.tar.xz 5553692 BLAKE2B f8f0d7d420375262b7db8ffcc1c9eb
DIST GraphicsMagick-1.3.42.tar.xz.asc 228 BLAKE2B 723f8d1ca13bd5b32a12d69bb46f4991df6e7963f0d4c12ddaf60167a9ade4c6fa36819cce1df202437143bc55e17dd6f2cff821412dafceeb3ab5e3dbf3dc7b SHA512 de5d90c748376e7e480a066e9354ac1771f15cb2d8c6e5c9249672fd811b7bbe06f97b3348240538fa8d0d7c11150f57fb5148285214712944f7535afb943bd0
DIST GraphicsMagick-1.3.43.tar.xz 5657460 BLAKE2B caa4fa6546acb4cdaaa421030ccc5cd2b628ae723e07f84700f65e26e1f3e59039cf92fda259ee44ba1e1fa90e9c469844fb5289cc73d50c42bb50fb39358ca2 SHA512 15b4d90119f25fd45f16d50218d51d543841dd3cdaf0c585bce2c18592106bc41573ed1011d7176ff5882fa0cded8f46bfd1e639c26063571109911e22098757
DIST GraphicsMagick-1.3.43.tar.xz.asc 228 BLAKE2B cb1290af98ea92de948df0421b7de101a713f0b8ce4a07959269d5edd10eb26f088585e1a8272482a9b219ee388ae8f040fc047ca76d5f752f04a7b57987c89c SHA512 3bd62bc64dd1b6f2d7a17f1281d8dc4c67c474860b4d95bfaf5fb4be93d0ee156b54c2a6ef4166687854e5458a6e43e61816a5fd508e4702f693a9d1e43984bf
+DIST GraphicsMagick-1.3.45.tar.xz 5936968 BLAKE2B 55c87c518267dc3330d09c39474acf4b89f06b2deddf8e5d36d3c235f39bb1ec5bd04d90e2dd6e50563430b58ea3b78ccb526bf8cf79efa32685ae8e04a1aee5 SHA512 2c12a24198a8ee1f86b4c43bf8903d129c891ec2c27ba22287dfc8a5f65c9223b2caa67a37b9a91b10b049ba8425e757738f5d92a9ae70abee76d323af9bd1a0
+DIST GraphicsMagick-1.3.45.tar.xz.asc 228 BLAKE2B 72c7554de7d45499f90fa6534ed819e4d40b5f878f8bf0b14b026e100390ee9cabddd9df0d3945664e559350f1621239fcb9aafa9987a26e346f52b2c2ad8215 SHA512 5f49c8d1cdd20cb5bd7b76660800d22ef8ab3b13c3954dc4feb7522cb1f4d343a8e98faa91094f616ecbb01ff770bc3f4dd252c62b6b70c780318d425730c5c1
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.45.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.45.ebuild
new file mode 100644
index 000000000000..ebd7600f3692
--- /dev/null
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.45.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_P=${P/graphicsm/GraphicsM}
+DESCRIPTION="Collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.graphicsmagick.org/ https://foss.heptapod.net/graphicsmagick/graphicsmagick"
+
+if [[ ${PV} == 9999 ]] ; then
+ EHG_REPO_URI="https://foss.heptapod.net/${PN}/${PN}"
+ inherit mercurial
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/bobfriesenhahn.asc
+ inherit verify-sig
+
+ SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}-history/$(ver_cut 1-2)/${MY_P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://downloads.sourceforge.net/project/${PN}/${PN}-history/$(ver_cut 1-2)/${MY_P}.tar.xz.asc )"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-bobfriesenhahn )"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV%.*}"
+IUSE="bzip2 +cxx debug dynamic-loading fpx heif imagemagick jbig jpeg jpeg2k jpegxl lcms lzma"
+IUSE+=" openmp perl png q16 q32 static-libs tcmalloc tiff truetype"
+IUSE+=" webp wmf X zip zlib zstd"
+
+RDEPEND="
+ dev-libs/libltdl
+ bzip2? ( app-arch/bzip2 )
+ fpx? ( media-libs/libfpx )
+ heif? ( media-libs/libheif:= )
+ imagemagick? ( !media-gfx/imagemagick )
+ jbig? ( media-libs/jbigkit )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpeg2k? ( media-libs/jasper:= )
+ jpegxl? ( media-libs/libjxl:= )
+ lcms? ( media-libs/lcms:2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:= )
+ tcmalloc? ( dev-util/google-perftools:= )
+ tiff? ( media-libs/tiff:= )
+ truetype? (
+ media-fonts/urw-fonts
+ >=media-libs/freetype-2
+ )
+ webp? ( media-libs/libwebp:= )
+ wmf? ( media-libs/libwmf )
+ X? (
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ zip? ( dev-libs/libzip:= )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND+=" virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.41-flags.patch
+ "${FILESDIR}"/${PN}-1.3.41-perl.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local depth=8
+
+ use q16 && depth=16
+ use q32 && depth=32
+
+ local myeconfargs=(
+ --enable-largefile
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable debug prof)
+ $(use_enable debug gcov)
+ $(use_enable imagemagick magick-compat)
+ $(use_enable openmp)
+ --with-threads
+ $(use_with dynamic-loading modules)
+ --with-quantum-depth=${depth}
+ --without-frozenpaths
+ $(use_with cxx magick-plus-plus)
+ $(use_with heif)
+ $(use_with jpegxl jxl)
+ $(use_with perl)
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_with bzip2 bzlib)
+ $(use_with fpx)
+ $(use_with jbig)
+ $(use_with webp)
+ $(use_with jpeg)
+ $(use_with jpeg2k jp2)
+ $(use_with lcms lcms2)
+ $(use_with lzma)
+ $(use_with png)
+ $(use_with tcmalloc)
+ $(use_with tiff)
+ --without-trio
+ $(use_with truetype ttf)
+ $(use_with wmf)
+ --with-fontpath="${EPREFIX}"/usr/share/fonts
+ --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+ --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
+ $(use_with zip libzip)
+ $(use_with zlib)
+ $(use_with zstd)
+ $(use_with X x)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ use perl && emake perl-build
+}
+
+src_test() {
+ # Some perl tests fail when DISPLAY is set
+ unset DISPLAY
+
+ default
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ emake -C PerlMagick DESTDIR="${D}" install
+
+ find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
+ find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
+ fi
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
+}
diff --git a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
index fd1d7bcb1476..ebd7600f3692 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
@@ -28,8 +28,8 @@ fi
LICENSE="MIT"
SLOT="0/${PV%.*}"
IUSE="bzip2 +cxx debug dynamic-loading fpx heif imagemagick jbig jpeg jpeg2k jpegxl lcms lzma"
-IUSE+=" openmp perl png postscript q16 q32 static-libs tcmalloc tiff truetype"
-IUSE+=" webp wmf X zlib zstd"
+IUSE+=" openmp perl png q16 q32 static-libs tcmalloc tiff truetype"
+IUSE+=" webp wmf X zip zlib zstd"
RDEPEND="
dev-libs/libltdl
@@ -45,7 +45,6 @@ RDEPEND="
lzma? ( app-arch/xz-utils )
perl? ( dev-lang/perl:= )
png? ( media-libs/libpng:= )
- postscript? ( app-text/ghostscript-gpl )
tcmalloc? ( dev-util/google-perftools:= )
tiff? ( media-libs/tiff:= )
truetype? (
@@ -59,6 +58,7 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXext
)
+ zip? ( dev-libs/libzip:= )
zlib? ( sys-libs/zlib )
zstd? ( app-arch/zstd:= )
"
@@ -108,7 +108,6 @@ src_configure() {
$(use_with perl)
--with-perl-options=INSTALLDIRS=vendor
$(use_with bzip2 bzlib)
- $(use_with postscript dps)
$(use_with fpx)
$(use_with jbig)
$(use_with webp)
@@ -125,6 +124,7 @@ src_configure() {
--with-fontpath="${EPREFIX}"/usr/share/fonts
--with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
--with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
+ $(use_with zip libzip)
$(use_with zlib)
$(use_with zstd)
$(use_with X x)
diff --git a/media-gfx/graphicsmagick/metadata.xml b/media-gfx/graphicsmagick/metadata.xml
index 99ba429c7cac..81b72dbdce7f 100644
--- a/media-gfx/graphicsmagick/metadata.xml
+++ b/media-gfx/graphicsmagick/metadata.xml
@@ -23,6 +23,7 @@
<flag name="dynamic-loading">Compile graphicsmagick with dynamically loadable modules</flag>
<flag name="q16">Set storage quantum size to 16 (~2*memory)</flag>
<flag name="q32">Set storage quantum size to 32 (~5*memory)</flag>
+ <flag name="zip">Build with <pkg>dev-libs/libzip</pkg> to support the OpenRaster (ORA) format.</flag>
</use>
<upstream>
<remote-id type="sourceforge">graphicsmagick</remote-id>