summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-12-21 09:03:00 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-12-21 09:03:08 +0100
commit84aefe3dc364492e74951b13ae62c8e63faf55dc (patch)
tree336596fc87ab8ed799bf18fda50d71fe2ae30dd9 /media-gfx
parentdev-ruby/railties: stabilize 7.0.8.6 for amd64 (diff)
downloadgentoo-84aefe3dc364492e74951b13ae62c8e63faf55dc.tar.gz
gentoo-84aefe3dc364492e74951b13ae62c8e63faf55dc.tar.bz2
gentoo-84aefe3dc364492e74951b13ae62c8e63faf55dc.zip
media-gfx/prusaslicer: updated live ebuild
Bug: https://bugs.gentoo.org/946720 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.9.0-missing-includes.patch10
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange-wrapper.patch18
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange.patch18
-rw-r--r--media-gfx/prusaslicer/prusaslicer-9999.ebuild4
4 files changed, 49 insertions, 1 deletions
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.9.0-missing-includes.patch b/media-gfx/prusaslicer/files/prusaslicer-2.9.0-missing-includes.patch
new file mode 100644
index 000000000000..d6b1fd097a40
--- /dev/null
+++ b/media-gfx/prusaslicer/files/prusaslicer-2.9.0-missing-includes.patch
@@ -0,0 +1,10 @@
+--- a/src/slic3r/GUI/UserAccountCommunication.cpp
++++ b/src/slic3r/GUI/UserAccountCommunication.cpp
+@@ -13,6 +13,7 @@
+ #include <boost/filesystem.hpp>
+ #include <boost/nowide/cstdio.hpp>
+ #include <boost/nowide/fstream.hpp>
++#include <boost/nowide/convert.hpp>
+ #include <curl/curl.h>
+ #include <string>
+
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange-wrapper.patch b/media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange-wrapper.patch
new file mode 100644
index 000000000000..a5a77d8fc370
--- /dev/null
+++ b/media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange-wrapper.patch
@@ -0,0 +1,18 @@
+From 09c89be8732d4b11f64980c7ac5368cd506847dd Mon Sep 17 00:00:00 2001
+From: Andreas Schneider <asn@cryptomilk.org>
+Date: Fri, 20 Dec 2024 20:15:51 +0100
+Subject: [PATCH] cmake: Install slic3r-arrange-wrapper
+
+Fixes #13805
+--- a/src/slic3r-arrange-wrapper/CMakeLists.txt
++++ b/src/slic3r-arrange-wrapper/CMakeLists.txt
+@@ -33,3 +33,9 @@ add_library(slic3r-arrange-wrapper
+ target_include_directories(slic3r-arrange-wrapper PRIVATE src)
+ target_include_directories(slic3r-arrange-wrapper PUBLIC include)
+ target_link_libraries(slic3r-arrange-wrapper PUBLIC slic3r-arrange)
++
++if (WIN32)
++ install(TARGETS slic3r-arrange-wrapper LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX})
++else()
++ install(TARGETS slic3r-arrange-wrapper LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++endif()
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange.patch b/media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange.patch
new file mode 100644
index 000000000000..7198d11f7464
--- /dev/null
+++ b/media-gfx/prusaslicer/files/prusaslicer-2.9.0-slic3r-arrange.patch
@@ -0,0 +1,18 @@
+From 5f450dc269ff99af3f0e056ae4b30d254789500b Mon Sep 17 00:00:00 2001
+From: Andreas Schneider <asn@cryptomilk.org>
+Date: Fri, 20 Dec 2024 20:14:52 +0100
+Subject: [PATCH] cmake: Install slic3r-arrange
+
+Fixes #13805
+--- a/src/slic3r-arrange/CMakeLists.txt
++++ b/src/slic3r-arrange/CMakeLists.txt
+@@ -32,3 +32,9 @@ add_library(slic3r-arrange
+ target_include_directories(slic3r-arrange PRIVATE src)
+ target_include_directories(slic3r-arrange PUBLIC include)
+ target_link_libraries(slic3r-arrange PUBLIC libslic3r)
++
++if (WIN32)
++ install(TARGETS slic3r-arrange LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX})
++else()
++ install(TARGETS slic3r-arrange LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++endif()
diff --git a/media-gfx/prusaslicer/prusaslicer-9999.ebuild b/media-gfx/prusaslicer/prusaslicer-9999.ebuild
index 1832088d5630..8e52edaf8502 100644
--- a/media-gfx/prusaslicer/prusaslicer-9999.ebuild
+++ b/media-gfx/prusaslicer/prusaslicer-9999.ebuild
@@ -62,12 +62,14 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2.6.0-dont-force-link-to-wayland-and-x11.patch"
- "${FILESDIR}/${PN}-2.8.0-missing-includes.patch"
"${FILESDIR}/${PN}-2.8.0-wxwidgets-3.2.4.patch"
"${FILESDIR}/${PN}-2.8.1-cgal-6.0.patch"
"${FILESDIR}/${PN}-2.8.1-fstream.patch"
"${FILESDIR}/${PN}-2.8.1-fix-libsoup-double-linking.patch"
+ "${FILESDIR}/${PN}-2.9.0-missing-includes.patch"
"${FILESDIR}/${PN}-2.9.0-fpic.patch"
+ "${FILESDIR}/${PN}-2.9.0-slic3r-arrange.patch"
+ "${FILESDIR}/${PN}-2.9.0-slic3r-arrange-wrapper.patch"
)
src_prepare() {