summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-19 15:51:42 -0400
committerRick Farina <zerochaos@gentoo.org>2020-05-21 12:27:31 -0400
commite2263e63d56bd9fdd3a8093cef65c8a6a3333ca6 (patch)
treee8823ff8201f8a36e880093735e6ad1a6be91347 /media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild
parentdev-php/pecl-uploadprogress: Revbump to fix missing installation files (diff)
downloadgentoo-e2263e63d56bd9fdd3a8093cef65c8a6a3333ca6.tar.gz
gentoo-e2263e63d56bd9fdd3a8093cef65c8a6a3333ca6.tar.bz2
gentoo-e2263e63d56bd9fdd3a8093cef65c8a6a3333ca6.zip
media-libs/elgato-streamdeck: initial ebuild
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild')
-rw-r--r--media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild
new file mode 100644
index 000000000000..07a7469b980d
--- /dev/null
+++ b/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+ SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"