summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-08-28 17:13:33 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-08-28 17:14:15 +0100
commit2380a875b7fe3af974889ade92fbd745bd3e388b (patch)
treeebfed7b62dc16f4a997d95b24059d42885678491 /media-libs/glew
parentmedia-libs/glew: new useflag wayland-only (diff)
downloadgentoo-2380a875b7fe3af974889ade92fbd745bd3e388b.tar.gz
gentoo-2380a875b7fe3af974889ade92fbd745bd3e388b.tar.bz2
gentoo-2380a875b7fe3af974889ade92fbd745bd3e388b.zip
media-libs/glew: Rename new wayland-only flag to egl-only
EGL is not Wayland-specific. It can be used with KMS, for example. Even X11 supports EGL, although GLEW doesn't seem to support that case. See https://github.com/nigels-com/glew/issues/328 for more details. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/glew')
-rw-r--r--media-libs/glew/glew-2.2.0-r1.ebuild6
-rw-r--r--media-libs/glew/metadata.xml3
2 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/glew/glew-2.2.0-r1.ebuild b/media-libs/glew/glew-2.2.0-r1.ebuild
index 5335393e4ec5..05123b7894e0 100644
--- a/media-libs/glew/glew-2.2.0-r1.ebuild
+++ b/media-libs/glew/glew-2.2.0-r1.ebuild
@@ -12,12 +12,12 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="BSD MIT"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-IUSE="doc static-libs wayland-only"
+IUSE="doc egl-only static-libs"
DEPEND="
>=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
>=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- !wayland-only? (
+ !egl-only? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
@@ -54,7 +54,7 @@ src_prepare() {
glew_system() {
# Set the SYSTEM variable instead of probing. #523444 #595280
- if use wayland-only; then
+ if use egl-only; then
echo "linux-egl"
else
case ${CHOST} in
diff --git a/media-libs/glew/metadata.xml b/media-libs/glew/metadata.xml
index 9dfc437a211d..f7add5ca6bd1 100644
--- a/media-libs/glew/metadata.xml
+++ b/media-libs/glew/metadata.xml
@@ -9,4 +9,7 @@
<remote-id type="github">nigels-com/glew</remote-id>
<remote-id type="sourceforge">glew</remote-id>
</upstream>
+ <use>
+ <flag name="egl-only">Enable EGL support and disable X11 support</flag>
+ </use>
</pkgmetadata>