summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/glu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/glu')
-rw-r--r--media-libs/glu/Manifest1
-rw-r--r--media-libs/glu/glu-9.0.0-r1.ebuild43
-rw-r--r--media-libs/glu/glu-9.0.0.ebuild82
-rw-r--r--media-libs/glu/metadata.xml5
4 files changed, 131 insertions, 0 deletions
diff --git a/media-libs/glu/Manifest b/media-libs/glu/Manifest
new file mode 100644
index 000000000000..30c62e73a49a
--- /dev/null
+++ b/media-libs/glu/Manifest
@@ -0,0 +1 @@
+DIST glu-9.0.0.tar.bz2 493206 SHA256 1f7ad0d379a722fcbd303aa5650c6d7d5544fde83196b42a73d1193568a4df12 SHA512 ff920e3fbca739794e1432a92fdd8517aa732110fea71ed724185425042f83ce18e9866c16f95c6e10f6993f0814a90fac9636e2b3d8ca2084d1ac0a860f61c8 WHIRLPOOL 3b63c789dc54da94bceae57601baad96b6d05901e262d2758f68163ed67d9d9bdecf49f96a2a2598891b0398d3403555e1be28d1c7f7deb7a95431cc2e2c2b1e
diff --git a/media-libs/glu/glu-9.0.0-r1.ebuild b/media-libs/glu/glu-9.0.0-r1.ebuild
new file mode 100644
index 000000000000..ae3c6f5c8a75
--- /dev/null
+++ b/media-libs/glu/glu-9.0.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ AUTOTOOLS_AUTORECONF=1
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools-multilib multilib ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="http://cgit.freedesktop.org/mesa/glu/"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PN}/${P}.tar.bz2"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}
+ !<media-libs/mesa-9
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-2_src_unpack
+}
+
+src_test() {
+ :;
+}
diff --git a/media-libs/glu/glu-9.0.0.ebuild b/media-libs/glu/glu-9.0.0.ebuild
new file mode 100644
index 000000000000..6af2878b6253
--- /dev/null
+++ b/media-libs/glu/glu-9.0.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools-utils multilib ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="http://cgit.freedesktop.org/mesa/glu/"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PN}/${P}.tar.bz2"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="multilib static-libs"
+
+DEPEND="virtual/opengl"
+RDEPEND="${DEPEND}
+ !<media-libs/mesa-9
+ multilib? ( !app-emulation/emul-linux-x86-opengl )"
+
+foreachabi() {
+ if use multilib; then
+ local ABI
+ for ABI in $(get_all_abis); do
+ multilib_toolchain_setup ${ABI}
+ AUTOTOOLS_BUILD_DIR=${WORKDIR}/${ABI} "${@}"
+ done
+ else
+ "${@}"
+ fi
+}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]] && has collision-protect ${FEATURES}; then
+ if [[ $(readlink "${EPREFIX}"/usr/$(get_libdir)/libGLU$(get_libname)) == *opengl* ]]; then
+ eerror "FEATURES=\"collision-protect\" is enabled, which will prevent overwriting"
+ eerror "symlinks that were formerly managed by eselect opengl. You must disable"
+ eerror "collision-protect or remove ${EPREFIX}/usr/$(get_libdir)/libGLU$(get_libname)*"
+ eerror "manually. For details see bug #435682."
+ die "collision-protect cannot overwrite libGLU$(get_libname)*"
+ fi
+ fi
+}
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-2_src_unpack
+}
+
+src_prepare() {
+ AUTOTOOLS_AUTORECONF=1 autotools-utils_src_prepare
+}
+
+src_configure() {
+ foreachabi autotools-utils_src_configure
+}
+
+src_compile() {
+ foreachabi autotools-utils_src_compile
+}
+
+src_install() {
+ foreachabi autotools-utils_src_install
+}
+
+src_test() {
+ :;
+}
diff --git a/media-libs/glu/metadata.xml b/media-libs/glu/metadata.xml
new file mode 100644
index 000000000000..7f7fe83cd799
--- /dev/null
+++ b/media-libs/glu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>x11</herd>
+</pkgmetadata>