summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-03-16 01:57:18 -0400
committerSam James <sam@gentoo.org>2023-03-20 05:35:39 +0000
commit19e111e291e62ab657919e3286442617a23d1f63 (patch)
treeeb06dd98cd42458ff281fab628039a36636ca2cb /media-libs/kvazaar/kvazaar-9999.ebuild
parentmedia-video/hevc-hm: new package, add 17.0 (diff)
downloadgentoo-19e111e291e62ab657919e3286442617a23d1f63.tar.gz
gentoo-19e111e291e62ab657919e3286442617a23d1f63.tar.bz2
gentoo-19e111e291e62ab657919e3286442617a23d1f63.zip
media-libs/kvazaar: add 2.2.0, wire up tests
Bug: https://bugs.gentoo.org/896120 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/30149 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/kvazaar/kvazaar-9999.ebuild')
-rw-r--r--media-libs/kvazaar/kvazaar-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-libs/kvazaar/kvazaar-9999.ebuild b/media-libs/kvazaar/kvazaar-9999.ebuild
index d44b2a4ef699..eae2fc58decc 100644
--- a/media-libs/kvazaar/kvazaar-9999.ebuild
+++ b/media-libs/kvazaar/kvazaar-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
GREATEST_PV="1.2.1"
@@ -11,7 +11,7 @@ if [[ ${PV} = *9999 ]] ; then
else
SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~amd64 ~mips"
fi
inherit autotools flag-o-matic multilib-minimal
@@ -30,6 +30,7 @@ RDEPEND=""
DEPEND="${RDEPEND}
test? (
media-video/ffmpeg
+ media-video/hevc-hm
)
abi_x86_32? ( ${ASM_DEP} )
abi_x86_64? ( ${ASM_DEP} )
@@ -46,11 +47,6 @@ src_prepare() {
fi
# Some m4 macros append Werror, we do not want that.
append-flags "-Wno-error"
-
- # valgrind isn't available on all archs
- # also, the valgrind tests fail with new ffmpeg (upstream only tests again ffmpeg 2.6.3)
- # see https://github.com/ultravideo/kvazaar/issues/216
- find "${S}/tests/" -type f -exec grep -q 'valgrind_test' '{}' \; -delete || die
}
multilib_src_configure() {
@@ -59,6 +55,10 @@ multilib_src_configure() {
$(use_enable static-libs static)
}
+multilib_src_test() {
+ KVZ_TEST_VALGRIND=0 emake check
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
}