summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild')
-rw-r--r--media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild b/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..b5e5c3242636
--- /dev/null
+++ b/media-libs/libaacplus/libaacplus-2.0.2-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib-minimal
+
+# This file cannot be mirrored.
+# See the notes at http://tipok.org.ua/node/17
+# The .tar.gz, ie the wrapper library, is lgpl though.
+TGPPDIST=26410-800.zip
+
+DESCRIPTION="HE-AAC+ v2 library, based on the reference implementation"
+HOMEPAGE="http://tipok.org.ua/node/17"
+SRC_URI="
+ http://dev.gentoo.org/~aballier/${P}.tar.gz
+ http://tipok.ath.cx/downloads/media/aac+/libaacplus/${P}.tar.gz
+ http://217.20.164.161/~tipok/aacplus/${P}.tar.gz
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.410/${TGPPDIST}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="fftw static-libs"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ !media-sound/aacplusenc
+ fftw? ( >=sci-libs/fftw-3.3.3-r2:3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ sed \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
+ -i configure.ac || die
+ eautoreconf
+ cp "${DISTDIR}/${TGPPDIST}" src/ || die
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_with fftw fftw3) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake -j1
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}