summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-09 21:01:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-10 10:30:45 +0100
commitc838cc19bed6c7df6768f4b4ceedccdb9f95e3cf (patch)
tree624a8105eeed1e513834452678a7bfb7397531e4 /media-libs/libldac
parentmedia-libs/libebur128: drop 1.2.6 (diff)
downloadgentoo-c838cc19bed6c7df6768f4b4ceedccdb9f95e3cf.tar.gz
gentoo-c838cc19bed6c7df6768f4b4ceedccdb9f95e3cf.tar.bz2
gentoo-c838cc19bed6c7df6768f4b4ceedccdb9f95e3cf.zip
media-libs/libldac: update EAPI 7 -> 8
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libldac')
-rw-r--r--media-libs/libldac/libldac-2.0.2.3-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-libs/libldac/libldac-2.0.2.3-r2.ebuild b/media-libs/libldac/libldac-2.0.2.3-r2.ebuild
new file mode 100644
index 000000000000..9354fb95f51f
--- /dev/null
+++ b/media-libs/libldac/libldac-2.0.2.3-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="LDAC codec library from AOSP"
+HOMEPAGE="https://android.googlesource.com/platform/external/libldac/"
+SRC_URI="https://github.com/EHfive/ldacBT/releases/download/v${PV}/ldacBT-${PV}.tar.gz"
+S="${WORKDIR}/ldacBT"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DLDAC_SOFT_FLOAT=OFF
+ -DINSTALL_LIBDIR=/usr/$(get_libdir)
+ )
+
+ cmake_src_configure
+}