summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-01-08 23:36:49 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-01-08 23:54:06 +0000
commit33009f15fd10e55a1d3911155f0027a7a4b879d7 (patch)
treebc49d9d19cbf87402425fb2ece7fed679df9d8c3 /media-libs/libsdl
parentmedia-libs/libsdl: Add live package targeting sdl12-compat (diff)
downloadgentoo-33009f15fd10e55a1d3911155f0027a7a4b879d7.tar.gz
gentoo-33009f15fd10e55a1d3911155f0027a7a4b879d7.tar.bz2
gentoo-33009f15fd10e55a1d3911155f0027a7a4b879d7.zip
media-libs/libsdl: Replace live ebuild with 1.2.60 release
sdl12-compat has now matured sufficiently that we do not need a live ebuild. This is still effectively a rewrite though, so I'm only adding the ~amd64 keyword to begin with. I have also reduced the number of USE flags to a minimum, so that SDL2 can be left to deal with flags such as pulseaudio. I want to drop the alsa flag too, but some packages still depend on this. I'll fix them up later. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/Manifest1
-rw-r--r--media-libs/libsdl/libsdl-1.2.60.ebuild38
-rw-r--r--media-libs/libsdl/libsdl-9999.ebuild36
3 files changed, 39 insertions, 36 deletions
diff --git a/media-libs/libsdl/Manifest b/media-libs/libsdl/Manifest
index 0bf126fb820c..78721ce1df25 100644
--- a/media-libs/libsdl/Manifest
+++ b/media-libs/libsdl/Manifest
@@ -1,3 +1,4 @@
DIST SDL-1.2.15_p20210224.tar.gz 3991106 BLAKE2B be0906950c80cddf15bc458f7734a3ebfa767b11e2f54bf9f771155f4420947900b95bbbebf01341d9dba4c1c7cfe9d54e43150e5f7781622b99668b3362adeb SHA512 3521fe996cf8a8ebb9beaa4802ac05cf5f3a2e7ed1c9b362a818d965b26ec8b3bbebfaac7c827feae44becf5bdd764378cb4282d129285f23a982b5c7474e006
DIST SDL-1.2.15_p20221103.tar.gz 4002891 BLAKE2B 2329cec3579a2eb226ee7c8566f7f995b21b4f7fac3a0b40f237cf2d13576347a001dac96caf35d7da0fa95b4ee1684fbb9972a82e2691e4c83c1c0984b46029 SHA512 bd2cf4119dd9be99094d3379b15067817d4d40490d894e2338da9c365378d79edcfe2d7df03f57ac948f5fd1f949e5acb5b2233be484084a828c98af350f1830
DIST SDL-1.2.15_p20221201.tar.gz 4002787 BLAKE2B 87b729cb16cfb36efa2b66166ef21d4c5c8bc99f8c8b4683885f04699122945a60512c5875d0c8425ddfe33b2eb901d11f27afbd9e3656cde3f30de5a5f1537c SHA512 5e70977cf5beaffebb28ae84f778e08d3cf56b2badda125ec1f08ac26c6b4e60a148d9ca9b2d7efee8a5fbc0b1a343d1d27a05be1c08e5d9251da67aea209659
+DIST libsdl-1.2.60.tar.gz 438381 BLAKE2B 32f00c8f5dc51780bfb48cdfa41ca46ab64dc4cd7d0a2a042e920569ea2d5fe3238e9e95b4bb34954a0f7b84a384cdbbc9859f20e2706192297a7e9d8696ee52 SHA512 4eae573054bb98d11356425392f352bf9c54b6406548d225bc8e8e042011e40edaaab6726ddc24e68f3e07cd21d95432df614f5381f1d3d5d0808686ea950732
diff --git a/media-libs/libsdl/libsdl-1.2.60.ebuild b/media-libs/libsdl/libsdl-1.2.60.ebuild
new file mode 100644
index 000000000000..7121bb32b6aa
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.60.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Simple Direct Media Layer 1.2 compatibility wrapper around SDL2"
+HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
+SRC_URI="https://github.com/libsdl-org/sdl12-compat/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+# IUSE dropped from real SDL1: aalib custom-cflags dga fbcon libcaca nas oss pulseaudio static-libs tslib xinerama xv
+IUSE="alsa +joystick opengl +sound test +video X"
+REQUIRED_USE="test? ( joystick opengl sound video )"
+# The tests are more like example programs.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/libsdl2[${MULTILIB_USEDEP},alsa=,joystick=,opengl=,sound=,video=,X=]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/opengl[${MULTILIB_USEDEP}] )
+"
+
+S="${WORKDIR}/sdl12-compat-release-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSDL12TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}
diff --git a/media-libs/libsdl/libsdl-9999.ebuild b/media-libs/libsdl/libsdl-9999.ebuild
deleted file mode 100644
index 2acec880995c..000000000000
--- a/media-libs/libsdl/libsdl-9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit git-r3 cmake-multilib
-
-DESCRIPTION="Simple Direct Media Layer (sdl-1.2 compatibility)"
-HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
-EGIT_REPO_URI="https://github.com/libsdl-org/sdl12-compat"
-LICENSE="ZLIB"
-SLOT="0"
-RESTRICT="!test? ( test )"
-
-# First line are fakes and just there for compat with other ebuilds
-IUSE="
- oss alsa nas X dga xv xinerama fbcon tslib aalib opengl libcaca +sound +video +joystick custom-cflags pulseaudio static-libs
- test
-"
-
-# IUSE inheritance dropped: dga, xv, fbcon, tflib, aalib, libcaca, custom-cflags, static-libs
-DEPEND="
- media-libs/libsdl2[oss?,alsa?,nas?,xinerama?,opengl?,sound?,video?,joystick?,pulseaudio?]
- X? ( || (
- media-libs/libsdl2[X]
- media-libs/libsdl2[wayland]
- ) )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DSDL12TESTS=$(usex test)
- )
-
- cmake-multilib_src_configure
-}