summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libsndfile/libsndfile-1.0.25.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libsndfile/libsndfile-1.0.25.ebuild')
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.25.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libsndfile/libsndfile-1.0.25.ebuild b/media-libs/libsndfile/libsndfile-1.0.25.ebuild
new file mode 100644
index 000000000000..d6dc8d087dda
--- /dev/null
+++ b/media-libs/libsndfile/libsndfile-1.0.25.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib
+
+MY_P=${P/_pre/pre}
+
+DESCRIPTION="A C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+if [[ "${MY_P}" == "${P}" ]]; then
+ SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.gz"
+else
+ SRC_URI="http://www.mega-nerd.com/tmp/${MY_P}b.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa minimal sqlite static-libs"
+
+RDEPEND="!minimal? ( >=media-libs/flac-1.2.1
+ >=media-libs/libogg-1.1.3
+ >=media-libs/libvorbis-1.2.3 )
+ alsa? ( media-libs/alsa-lib )
+ sqlite? ( >=dev-db/sqlite-3.2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+# Keep this function synced with x11-libs/pango ebuild!
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" = "lib32" ] )
+}
+
+src_prepare() {
+ sed -i -e 's:noinst_PROGRAMS:check_PROGRAMS:' {examples,tests}/Makefile.am || die
+
+ epatch "${FILESDIR}"/${PN}-1.0.17-regtests-need-sqlite.patch
+
+ AT_M4DIR=M4 eautoreconf
+ epunt_cxx
+}
+
+src_configure() {
+ multilib_enabled && append-lfs-flags #313259
+
+ econf \
+ $(use_enable sqlite) \
+ $(use_enable static-libs static) \
+ $(use_enable alsa) \
+ $(use_enable !minimal external-libs) \
+ htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-octave \
+ --disable-gcc-werror \
+ --disable-gcc-pipe
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldocdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dodoc AUTHORS ChangeLog NEWS README
+}