summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2023-06-30 18:25:22 +0200
committerStephan Hartmann <sultan@gentoo.org>2023-06-30 18:25:48 +0200
commit3b41cdefc20c6fa856e84e96ed94bc9bda7ba9e1 (patch)
treebee50767104918c3dc46bc3a94aa6823db61794e /media-libs/libwebp
parentnet-libs/xrootd: add 5.6.0 (diff)
downloadgentoo-3b41cdefc20c6fa856e84e96ed94bc9bda7ba9e1.tar.gz
gentoo-3b41cdefc20c6fa856e84e96ed94bc9bda7ba9e1.tar.bz2
gentoo-3b41cdefc20c6fa856e84e96ed94bc9bda7ba9e1.zip
media-libs/libwebp: backport fix for CVE-2023-1999
Bug: https://bugs.gentoo.org/909369 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'media-libs/libwebp')
-rw-r--r--media-libs/libwebp/files/libwebp-1.2.4-CVE-2023-1999.patch50
-rw-r--r--media-libs/libwebp/libwebp-1.2.4-r2.ebuild78
2 files changed, 128 insertions, 0 deletions
diff --git a/media-libs/libwebp/files/libwebp-1.2.4-CVE-2023-1999.patch b/media-libs/libwebp/files/libwebp-1.2.4-CVE-2023-1999.patch
new file mode 100644
index 000000000000..9c023712a5aa
--- /dev/null
+++ b/media-libs/libwebp/files/libwebp-1.2.4-CVE-2023-1999.patch
@@ -0,0 +1,50 @@
+commit a486d800b60d0af4cc0836bf7ed8f21e12974129
+Author: James Zern <jzern@google.com>
+Date: Wed Feb 22 22:15:47 2023 -0800
+
+ EncodeAlphaInternal: clear result->bw on error
+
+ This avoids a double free should the function fail prior to
+ VP8BitWriterInit() and a previous trial result's buffer carried over.
+ Previously in ApplyFiltersAndEncode() trial.bw (with a previous
+ iteration's buffer) would be freed, followed by best.bw pointing to the
+ same buffer.
+
+ Since:
+ 187d379d add a fallback to ALPHA_NO_COMPRESSION
+
+ In addition, check the return value of VP8BitWriterInit() in this
+ function.
+
+ Bug: webp:603
+ Change-Id: Ic258381ee26c8c16bc211d157c8153831c8c6910
+
+diff --git a/src/enc/alpha_enc.c b/src/enc/alpha_enc.c
+index f7c02690..7d205586 100644
+--- a/src/enc/alpha_enc.c
++++ b/src/enc/alpha_enc.c
+@@ -13,6 +13,7 @@
+
+ #include <assert.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "src/enc/vp8i_enc.h"
+ #include "src/dsp/dsp.h"
+@@ -148,6 +149,7 @@ static int EncodeAlphaInternal(const uint8_t* const data, int width, int height,
+ }
+ } else {
+ VP8LBitWriterWipeOut(&tmp_bw);
++ memset(&result->bw, 0, sizeof(result->bw));
+ return 0;
+ }
+ }
+@@ -162,7 +164,7 @@ static int EncodeAlphaInternal(const uint8_t* const data, int width, int height,
+ header = method | (filter << 2);
+ if (reduce_levels) header |= ALPHA_PREPROCESSED_LEVELS << 4;
+
+- VP8BitWriterInit(&result->bw, ALPHA_HEADER_LEN + output_size);
++ if (!VP8BitWriterInit(&result->bw, ALPHA_HEADER_LEN + output_size)) ok = 0;
+ ok = ok && VP8BitWriterAppend(&result->bw, &header, ALPHA_HEADER_LEN);
+ ok = ok && VP8BitWriterAppend(&result->bw, output, output_size);
+
diff --git a/media-libs/libwebp/libwebp-1.2.4-r2.ebuild b/media-libs/libwebp/libwebp-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..bcf5f8174336
--- /dev/null
+++ b/media-libs/libwebp/libwebp-1.2.4-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="A lossy image compression format"
+HOMEPAGE="https://developers.google.com/speed/webp/download"
+SRC_URI="https://storage.googleapis.com/downloads.webmproject.org/releases/webp/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0/7" # subslot = libwebp soname version
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 gif +jpeg opengl +png static-libs swap-16bit-csp tiff"
+
+# TODO: dev-lang/swig bindings in swig/ subdirectory
+RDEPEND="gif? ( media-libs/giflib:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ opengl? (
+ media-libs/freeglut
+ virtual/opengl
+ )
+ png? ( media-libs/libpng:= )
+ tiff? ( media-libs/tiff:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.3-libpng-pkg-config.patch
+ "${FILESDIR}"/${PN}-1.2.4-CVE-2023-1999.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix libtool relinking, bug #499270.
+ #elibtoolize
+
+ # Needed for pkg-config patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local args=(
+ --enable-libwebpmux
+ --enable-libwebpdemux
+ --enable-libwebpdecoder
+ $(use_enable static-libs static)
+ $(use_enable swap-16bit-csp)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable opengl gl)
+ $(use_enable tiff)
+
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_x86_sse4_1 sse4.1)
+ $(use_enable cpu_flags_arm_neon neon)
+
+ # Only used for gif2webp binary wrt bug #486646
+ $(multilib_native_use_enable gif)
+ )
+
+ ECONF_SOURCE="${S}" econf "${args[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+ dodoc AUTHORS ChangeLog doc/*.txt NEWS README.md
+}