summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-05-29 14:28:16 +0200
committerSebastian Pipping <sping@gentoo.org>2021-05-29 14:29:36 +0200
commit6da319e882d206d3bcba387a803a588932501ae9 (patch)
tree578e55b90fd447254a74379da8fef70cd307d60f /media-libs/libxspf/libxspf-1.2.1.ebuild
parentmail-mta/exim-4.94.2-r2: allow moving away from sys-libs/db (diff)
downloadgentoo-6da319e882d206d3bcba387a803a588932501ae9.tar.gz
gentoo-6da319e882d206d3bcba387a803a588932501ae9.tar.bz2
gentoo-6da319e882d206d3bcba387a803a588932501ae9.zip
media-libs/libxspf: 1.2.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.19, Repoman-3.0.3
Diffstat (limited to 'media-libs/libxspf/libxspf-1.2.1.ebuild')
-rw-r--r--media-libs/libxspf/libxspf-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libxspf/libxspf-1.2.1.ebuild b/media-libs/libxspf/libxspf-1.2.1.ebuild
new file mode 100644
index 000000000000..d14dc695b584
--- /dev/null
+++ b/media-libs/libxspf/libxspf-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Playlist handling library"
+HOMEPAGE="http://libspiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libspiff/${P}.tar.bz2"
+
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/expat-2
+ >=dev-libs/uriparser-0.7.5"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cpptest-1.1 )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-doc \
+ --disable-static \
+ $(use_enable test)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}