summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-06-15 15:40:54 +0200
committerMatt Turner <mattst88@gentoo.org>2023-06-16 16:24:22 -0400
commit0c628930a95b68330942158cd315ff66f286cb23 (patch)
tree282ec5d5f7fafcc4a4554b2f83fcddcd06e4150d /media-libs/mesa/mesa-9999.ebuild
parentnet-misc/memcached: add 1.6.21 (diff)
downloadgentoo-0c628930a95b68330942158cd315ff66f286cb23.tar.gz
gentoo-0c628930a95b68330942158cd315ff66f286cb23.tar.bz2
gentoo-0c628930a95b68330942158cd315ff66f286cb23.zip
media-libs/mesa: add Vulkan software rasterizer as VIDEO_CARDS=lavapipe
Mesa includes a software rasterizer for vulkan ("lavapipe") based on llvmpipe. Add lavapipe to VIDEO_CARDS to enable it. Bug: https://bugs.gentoo.org/818019 Closes: https://github.com/gentoo/gentoo/pull/31455 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index f92b393b0f53..0b34a1fa96ec 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -25,7 +25,7 @@ SLOT="0"
RESTRICT="!test? ( test )"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lima nouveau panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -49,6 +49,7 @@ REQUIRED_USE="
)
vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
+ video_cards_lavapipe? ( llvm vulkan )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_radeonsi? ( llvm )
@@ -377,6 +378,7 @@ multilib_src_configure() {
fi
if use vulkan; then
+ vulkan_enable video_cards_lavapipe swrast
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel intel_hasvk
vulkan_enable video_cards_d3d12 microsoft-experimental