summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-17 08:16:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-17 08:16:57 +0200
commit934f8250f76673d3cac61753ed71d83d49fb961e (patch)
tree7d7f74ce7f6617ff887bfa51c5e901cfe0a36ab9 /media-libs/sdl-pango
parentdev-util/cucumber-tag_expressions: add ruby25 (diff)
downloadgentoo-934f8250f76673d3cac61753ed71d83d49fb961e.tar.gz
gentoo-934f8250f76673d3cac61753ed71d83d49fb961e.tar.bz2
gentoo-934f8250f76673d3cac61753ed71d83d49fb961e.zip
media-libs/sdl-pango: Revbump to fix installation of .so file.
Also bumped to EAPI-6. Thanks to Arfrever Frehtes Taifersar Arahesis for his outstanding analysis on the issue. Closes: https://bugs.gentoo.org/655856 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'media-libs/sdl-pango')
-rw-r--r--media-libs/sdl-pango/sdl-pango-0.1.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/sdl-pango/sdl-pango-0.1.2-r1.ebuild b/media-libs/sdl-pango/sdl-pango-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..ddaf3df1d5d8
--- /dev/null
+++ b/media-libs/sdl-pango/sdl-pango-0.1.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="connect the text rendering engine of GNOME to SDL"
+HOMEPAGE="http://sdlpango.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdlpango/SDL_Pango-${PV}.tar.gz
+ http://zarb.org/~gc/t/SDL_Pango-0.1.2-API-adds.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="x11-libs/pango
+ media-libs/libsdl[video]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/SDL_Pango-${PV}"
+
+src_unpack() {
+ unpack SDL_Pango-${PV}.tar.gz
+}
+
+src_prepare() {
+ default
+ eapply -p0 "${DISTDIR}"/SDL_Pango-0.1.2-API-adds.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}