summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-23 14:34:55 +0100
committerSam James <sam@gentoo.org>2023-05-30 19:03:57 +0100
commit0dd5d6fbb4c625771b3de036043e8bf7e2d15844 (patch)
treedca226d17c6cdffe5e4ec69e29cf8d2908d38ce5 /media-libs
parentdev-java/java-config: replace @GENTOO_PORTAGE_EPREFIX@ in launcher.bash (diff)
downloadgentoo-0dd5d6fbb4c625771b3de036043e8bf7e2d15844.tar.gz
gentoo-0dd5d6fbb4c625771b3de036043e8bf7e2d15844.tar.bz2
gentoo-0dd5d6fbb4c625771b3de036043e8bf7e2d15844.zip
media-libs/gstreamer: add 1.22.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.22.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index 996453d42e21..8f3c56ab9b26 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -1,3 +1,4 @@
DIST gstreamer-1.20.3.tar.xz 2681088 BLAKE2B 423669ff2224cc5d9b979a1353eb1dbcaea5dacca374e83630abf23574f813cbecf5144cdd3209f638aeb50e6764004c3d8020db7f11b21726a9f4b56b513d10 SHA512 e93f9fbf2d7a839dcbe2030ed16dd53eb250741db7c2f1cea396c23e4fabf9a0caff6be4babf7c10aec4b56dc8319a970b1b0bfa6eea2e36aed3e6e1265d9278
DIST gstreamer-1.20.4.tar.xz 2686324 BLAKE2B b54da03f93f0062df0ada5534f3eff8a37e4b41f404b4bdd466bb6371e3db61a40741d723392bcc7cf7f46cded26c5d8ca625748670ac98daec136b0fb76a810 SHA512 33ba08e67b21a3e2e5dc5caeeae66e561b9d64ae863331a209e711f60a652ba38635e8bb963336e73b9afd5cf38e17139fbf933ca621d040f0d6e22a18ba7ad8
DIST gstreamer-1.20.5.tar.xz 2690968 BLAKE2B cca6385b1fcc10928ad19e587ebb6ce202097f4a33d79555c969d3906dacc7e5074fc8f42a0566e40aa333502764ad0b491d610c05ef1921ad370bf5f5883afd SHA512 90c5f5865877170bb0dc570e61c22c27dea5adae2d9c304227da266b5b5b2eccd98ed21943f14bb5dfe169f4e020b8ac457a5d540363dfe2547180f34a3c7b29
+DIST gstreamer-1.22.3.tar.xz 1785496 BLAKE2B 6de024992b38c66a0c5906cffae8df8ca85bc3d7554d323643ed0642a0e561cbf24a363d8acd2e9e540c5fecb07e4e59028cfb70d135c7e23e59c3dc004ccb73 SHA512 b316496f114acd687529cf71645fb75b8a4ac6baf01d9659e8ef8b22771b6c5ea8c5087a31ca633464ebd46656684ab382a15c2c11872ce5d218e726f4e56d09
diff --git a/media-libs/gstreamer/gstreamer-1.22.3.ebuild b/media-libs/gstreamer/gstreamer-1.22.3.ebuild
new file mode 100644
index 000000000000..5feb391a8112
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.22.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+caps +introspection +orc unwind"
+
+# gstreamer-1.22.x requires 2.62, but 2.64 is strongly recommended
+RDEPEND="
+ >=dev-libs/glib-2.64.0:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ unwind? (
+ >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ )
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( AUTHORS ChangeLog NEWS MAINTAINERS README.md RELEASE )
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dcheck=enabled
+ $(meson_feature unwind libunwind)
+ $(meson_feature unwind libdw)
+ )
+
+ if use caps ; then
+ emesonargs+=( -Dptp-helper-permissions=capabilities )
+ else
+ emesonargs+=(
+ -Dptp-helper-permissions=setuid-root
+ -Dptp-helper-setuid-user=nobody
+ -Dptp-helper-setuid-group=nobody
+ )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ DESTDIR="${D}" eninja install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/bin/gst-launch-${SLOT}"
+}