summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-06-12 18:01:51 +0000
committerSam James <sam@gentoo.org>2023-06-12 19:03:09 +0100
commit54270ba63127af2de00546cbdd15c560fd820146 (patch)
treeb33d8156175af3ff39ca4f5de0e5628fe956d966 /media-libs
parentapp-admin/eselect: Stabilize 1.4.22-r1 x86, #908415 (diff)
downloadgentoo-54270ba63127af2de00546cbdd15c560fd820146.tar.gz
gentoo-54270ba63127af2de00546cbdd15c560fd820146.tar.bz2
gentoo-54270ba63127af2de00546cbdd15c560fd820146.zip
media-libs/mlt: Backport -Wint-conversion fix
Signed-off-by: Violet Purcell <vimproved@inventati.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mlt/files/mlt-7.14.0-int-conversion.patch53
-rw-r--r--media-libs/mlt/mlt-7.14.0-r1.ebuild (renamed from media-libs/mlt/mlt-7.14.0.ebuild)1
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/mlt/files/mlt-7.14.0-int-conversion.patch b/media-libs/mlt/files/mlt-7.14.0-int-conversion.patch
new file mode 100644
index 000000000000..8a3acdcc7048
--- /dev/null
+++ b/media-libs/mlt/files/mlt-7.14.0-int-conversion.patch
@@ -0,0 +1,53 @@
+Upstream: https://github.com/mltframework/mlt/commit/db1f3ceff723912c2ff4b6207a3f446f6677e8f8
+
+From db1f3ceff723912c2ff4b6207a3f446f6677e8f8 Mon Sep 17 00:00:00 2001
+From: j-b-m <jb@kdenlive.org>
+Date: Sun, 2 Apr 2023 18:14:20 +0200
+Subject: [PATCH] Fix compilation: parameter type mismatch
+
+* Fix compilation: parameter type mismatch
+
+* Fix incompatible arg
+--- a/src/modules/avformat/factory.c
++++ b/src/modules/avformat/factory.c
+@@ -31,7 +31,7 @@ extern mlt_filter filter_swresample_init( mlt_profile profile, char *arg );
+ extern mlt_filter filter_swscale_init( mlt_profile profile, char *arg );
+ extern mlt_producer producer_avformat_init( mlt_profile profile, const char *service, char *file );
+ extern mlt_filter filter_avfilter_init( mlt_profile, mlt_service_type, const char*, char* );
+-extern mlt_link link_swresample_init( mlt_profile profile, char *arg );
++extern mlt_link link_swresample_init( mlt_profile profile, mlt_service_type, const char *, char * );
+
+ // ffmpeg Header files
+ #include <libavformat/avformat.h>
+@@ -94,7 +94,7 @@ static void *create_service( mlt_profile profile, mlt_service_type type, const c
+ if ( type == mlt_service_filter_type )
+ return filter_swresample_init( profile, arg );
+ else if ( type == mlt_service_link_type )
+- return link_swresample_init( profile, arg );
++ return link_swresample_init( profile, type, id, arg );
+ #endif
+ return NULL;
+ }
+--- a/src/win32/win32.c
++++ b/src/win32/win32.c
+@@ -70,7 +70,7 @@ int setenv(const char *name, const char *value, int overwrite)
+
+ static int iconv_from_utf8( mlt_properties properties, const char *prop_name, const char *prop_name_out, const char* encoding )
+ {
+- char *text = mlt_properties_get( properties, prop_name );
++ const char *text = mlt_properties_get( properties, prop_name );
+ int result = 0;
+
+ if ( text ) {
+@@ -99,7 +99,7 @@ static int iconv_from_utf8( mlt_properties properties, const char *prop_name, co
+
+ static int iconv_to_utf8( mlt_properties properties, const char *prop_name, const char *prop_name_out, const char* encoding )
+ {
+- char *text = mlt_properties_get( properties, prop_name );
++ const char *text = mlt_properties_get( properties, prop_name );
+ int result = 0;
+
+ if ( text ) {
+--
+2.41.0
+
diff --git a/media-libs/mlt/mlt-7.14.0.ebuild b/media-libs/mlt/mlt-7.14.0-r1.ebuild
index 3f53d04db981..2e4aa2447770 100644
--- a/media-libs/mlt/mlt-7.14.0.ebuild
+++ b/media-libs/mlt/mlt-7.14.0-r1.ebuild
@@ -84,6 +84,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.10.0-swig-underlinking.patch
"${FILESDIR}"/${PN}-6.22.1-no_lua_bdepend.patch
"${FILESDIR}"/${PN}-7.0.1-cmake-symlink.patch
+ "${FILESDIR}"/${PN}-7.14.0-int-conversion.patch
)
pkg_setup() {