summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-12-30 09:00:42 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-12-30 09:07:27 +0200
commit8755ed4450bb629cc8059695be79b2a959862819 (patch)
tree352c03ab66e10ce1f6562ac160f691bbb2a02c3f /media-libs
parentsys-libs/musl: Stabilize 1.2.3-r8 ppc64, #920977 (diff)
downloadgentoo-8755ed4450bb629cc8059695be79b2a959862819.tar.gz
gentoo-8755ed4450bb629cc8059695be79b2a959862819.tar.bz2
gentoo-8755ed4450bb629cc8059695be79b2a959862819.zip
media-libs/netpbm: add 11.5.1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/netpbm/Manifest1
-rw-r--r--media-libs/netpbm/netpbm-11.5.1.ebuild253
2 files changed, 254 insertions, 0 deletions
diff --git a/media-libs/netpbm/Manifest b/media-libs/netpbm/Manifest
index e9ca22bc6604..6521fae153d3 100644
--- a/media-libs/netpbm/Manifest
+++ b/media-libs/netpbm/Manifest
@@ -2,3 +2,4 @@ DIST netpbm-11.2.4.tar.xz 3791116 BLAKE2B bc3c4c7dd1c473cf6a0511c1a756dc11ddac69
DIST netpbm-11.2.5.tar.xz 3791980 BLAKE2B 147297cd35a114f278410bfc4837d632bd2d8815a461b4288d87808bc4cba4480d4ab41c7365d9845f0bb2c94f295907a0fbcbb0b8cfef64f6581e435efd5842 SHA512 de23a62b74c6a0020e0a178d14f64e87c79f94c56c132e3f3e4c895d2d4d27580fa6ed2310b31bd476b9922672dcf9833cde5fb5b5b0ea094b01c520fcd24059
DIST netpbm-11.2.7.tar.xz 3780372 BLAKE2B 8a6a75bd0358acf21faa3defd2b3ca886aacd38a28a1f8b65280a9d6c1667102a47efb734fe2ff2dfae38a5d0995b5efaa4b3ec70138bac7ad07e3e6e79c6063 SHA512 3fb00524b958d97304066749d4117b11ce5e23b7c8e08e68bfb5109575cc40a52dbe0f44559e6c0832a4397298efbea50a8ed0b9d2b57e41a09275729574bace
DIST netpbm-11.5.0.tar.xz 3781848 BLAKE2B ffb70664a0dc7f8800c743b043a43d04cc80dfb8dccea9e464ae11bad24a77fcd5635dd58fb0d9c82c72b680b4ca374735894438e854f918fc30529abea0d943 SHA512 b015952e725b7db90a2759766c6a3bc9628aea6f769da7fa2455fba787992e4391b2a8a998fc619a918846c1aa7899192036731c1d1aa9104e494a9173f72779
+DIST netpbm-11.5.1.tar.xz 3781792 BLAKE2B 40773f81bba1e2231009d0e3b3950eb6bf5c22a4a9d02c42db76536d1b70140a1b462e3dc6db29bc5a822c0f9d72463d4ed3a390e199bcd4bb7a9c7495570f1e SHA512 05fa20fdabc175c99c89e779ffa719b0447ce97b4a6851f17afdf247dd3e67787ce251e28b5529bb793d46164b0c3908a368a77e0a5245c49109767f7870676d
diff --git a/media-libs/netpbm/netpbm-11.5.1.ebuild b/media-libs/netpbm/netpbm-11.5.1.ebuild
new file mode 100644
index 000000000000..d4ca332ca116
--- /dev/null
+++ b/media-libs/netpbm/netpbm-11.5.1.ebuild
@@ -0,0 +1,253 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic multilib toolchain-funcs
+
+# Upstream has 3 flavors of netpbm: super stable, stable and advanced.
+# They only provide a tarball for super stable, but super stable is a bit lagging.
+# So we package the stable branch of their svn (currently versions 11.2.xx) on SLOT "0/stable[.rev]"
+# and the advanced branch of their svn (currently versions 11.4.yy) on SLOT "0/advanced[.rev]".
+# The stable branch is stabilized according to usual Gentoo rules, while the
+# advanced branch will not be stabilized.
+# A detailed explanation is here https://netpbm.sourceforge.net/release.html
+
+DESCRIPTION="A set of utilities for converting to/from the netpbm (and related) formats"
+HOMEPAGE="https://netpbm.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="Artistic BSD GPL-2 IJG LGPL-2.1 MIT public-domain"
+SLOT="0/advanced"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="jbig jpeg png postscript rle cpu_flags_x86_sse2 static-libs svga tiff X xml"
+
+# app-text/ghostscript-gpl is really needed for postscript
+# some utilities execute /usr/bin/gs
+# some installed programs are perl scripts
+RDEPEND="
+ dev-lang/perl
+ jbig? ( media-libs/jbigkit:= )
+ jpeg? ( media-libs/libjpeg-turbo:=[static-libs?] )
+ png? (
+ >=media-libs/libpng-1.4:0=
+ sys-libs/zlib
+ )
+ postscript? (
+ app-text/ghostscript-gpl
+ sys-libs/zlib
+ )
+ rle? ( media-libs/urt:= )
+ svga? ( media-libs/svgalib )
+ tiff? ( >=media-libs/tiff-3.5.5:= )
+ xml? ( dev-libs/libxml2 )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/netpbm-10.86.21-build.patch
+ "${FILESDIR}"/netpbm-11.0.0-misc-deps.patch
+ "${FILESDIR}"/netpbm-11.1.0-fix-clang-O2.patch
+)
+
+netpbm_libtype() {
+ case ${CHOST} in
+ *-darwin*) echo dylib;;
+ *) echo unixshared;;
+ esac
+}
+
+netpbm_libsuffix() {
+ local suffix=$(get_libname)
+ echo ${suffix//\.}
+}
+
+netpbm_ldshlib() {
+ case ${CHOST} in
+ *-darwin*) echo '$(LDFLAGS) -dynamiclib -install_name $(SONAME)';;
+ *) echo '$(LDFLAGS) -shared -Wl,-soname,$(SONAME)';;
+ esac
+}
+
+netpbm_config_lib() {
+ usex ${1} -l${2:-$1} NONE
+}
+
+# for bug #828127
+netpbm_cflags_for_build() {
+ if is-flagq -fPIC; then
+ echo -fPIC
+ fi
+}
+
+src_prepare() {
+ default
+
+ # make sure we use system libs
+ sed '/SUPPORT_SUBDIRS/s:urt::' -i GNUmakefile || die
+ rm -r urt converter/other/jbig/libjbig converter/other/jpeg2000/libjasper || die
+
+ # take care of the importinc stuff ourselves by only doing it once
+ # at the top level and having all subdirs use that one set #149843
+ sed \
+ -e '/^importinc:/s|^|importinc:\nmanual_|' \
+ -e '/-Iimportinc/s|-Iimp|-I"$(BUILDDIR)"/imp|g'\
+ -i common.mk || die
+ sed \
+ -e '/%.c/s: importinc$::' \
+ -i common.mk lib/Makefile lib/util/Makefile || die
+ sed \
+ -e 's:pkg-config:$(PKG_CONFIG):' \
+ -i GNUmakefile converter/other/Makefile other/pamx/Makefile || die
+
+ # The postscript knob is currently bound up with a fork test.
+ if ! use postscript ; then
+ sed \
+ -e 's:$(DONT_HAVE_PROCESS_MGMT):Y:' \
+ -i converter/other/Makefile generator/Makefile || die
+ sed -r \
+ -e 's:(pbmtextps|pnmtops|pstopnm).*::' \
+ -i test/all-in-place.{ok,test} || die
+ sed \
+ -e 's:lps-roundtrip.*::' \
+ -e 's:pbmtextps-dump.*::' \
+ -e 's:pbmtextps.*::' \
+ -i test/Test-Order || die
+ sed \
+ -e '/^$/d' \
+ -i test/all-in-place.ok || die
+ sed \
+ '2iexit 80' \
+ -i test/ps-{alt-,flate-,}roundtrip.test || die
+ fi
+
+ # the new postscript test needs +x
+ chmod +x test/lps-roundtrip.test || die
+
+ # Do not test png if not built
+ if ! use png ; then
+ sed -E \
+ -e 's:(pamtopng|pngtopam|pnmtopng).*::' \
+ -i test/all-in-place.{ok,test} || die
+ sed \
+ -e '/^$/d' \
+ -i test/all-in-place.ok || die
+
+ sed -E \
+ -e 's:(pamrgbatopng|pngtopnm).*::' \
+ -i test/legacy-names.{ok,test} || die
+ sed \
+ -e '/^$/d' \
+ -i test/legacy-names.ok || die
+ sed \
+ -e 's:png-roundtrip.*::' \
+ -e 's:winicon-roundtrip.*::' \
+ -i test/Test-Order || die
+ fi
+
+ # this test requires LC_ALL=en_US.iso88591, not available on musl
+ if use elibc_musl; then
+ sed \
+ -e 's:pbmtext-iso88591.*::' \
+ -i test/Test-Order || die
+ fi
+}
+
+src_configure() {
+ cat config.mk.in - >> config.mk <<-EOF || die "writing config.mk failed"
+ # Misc stuff
+ BUILD_FIASCO = N
+ SYMLINK = ln -sf
+
+ # These vars let src_test work by default
+ PKGDIR_DEFAULT = ${T}/netpbm
+ RESULTDIR_DEFAULT = ${T}/netpbm-test
+
+ # Toolchain options
+ CC = $(tc-getCC) -Wall
+ LD = \$(CC)
+ CC_FOR_BUILD = $(tc-getBUILD_CC)
+ LD_FOR_BUILD = \$(CC_FOR_BUILD)
+ AR = $(tc-getAR)
+ RANLIB = $(tc-getRANLIB)
+ PKG_CONFIG = $(tc-getPKG_CONFIG)
+
+ STRIPFLAG =
+ CFLAGS_SHLIB = -fPIC
+ CFLAGS_FOR_BUILD += $(netpbm_cflags_for_build)
+
+ LDRELOC = \$(LD) -r
+ LDSHLIB = $(netpbm_ldshlib)
+ LINKER_CAN_DO_EXPLICIT_LIBRARY = N # we can, but dont want to
+ LINKERISCOMPILER = Y
+ NETPBMLIBSUFFIX = $(netpbm_libsuffix)
+ NETPBMLIBTYPE = $(netpbm_libtype)
+ STATICLIB_TOO = $(usex static-libs Y N)
+
+ # The var is called SSE, but the code is actually SSE2.
+ WANT_SSE = $(usex cpu_flags_x86_sse2 Y N)
+
+ # Gentoo build options
+ TIFFLIB = $(netpbm_config_lib tiff)
+ # Let tiff worry about its own dependencies #395753
+ TIFFLIB_NEEDS_JPEG = N
+ TIFFLIB_NEEDS_Z = N
+ JPEGLIB = $(netpbm_config_lib jpeg)
+ PNGLIB = $(netpbm_config_lib png)
+ ZLIB = $($(tc-getPKG_CONFIG) --libs zlib)
+ LINUXSVGALIB = $(netpbm_config_lib svga vga)
+ XML2_LIBS = $(netpbm_config_lib xml xml2)
+ JBIGLIB = $(netpbm_config_lib jbig)
+ JBIGHDR_DIR =
+ JASPERLIB = NONE
+ JASPERHDR_DIR =
+ URTLIB = $(netpbm_config_lib rle)
+ URTHDR_DIR =
+ X11LIB = $(netpbm_config_lib X X11)
+ X11HDR_DIR =
+ EOF
+}
+
+src_compile() {
+ emake -j1 pm_config.h version.h manual_importinc #149843
+ emake
+}
+
+src_test() {
+ # The code wants to install everything first and then test the result.
+ emake install.{bin,lib,data}
+ emake check
+}
+
+src_install() {
+ # Subdir make targets like to use `mkdir` all over the place
+ # without any actual dependencies, thus the -j1.
+ emake -j1 package pkgdir="${ED}"/usr
+
+ if [[ $(get_libdir) != "lib" ]] ; then
+ mv "${ED}"/usr/lib "${ED}"/usr/$(get_libdir) || die
+ fi
+
+ # Remove cruft that we don't need, and move around stuff we want
+ rm "${ED}"/usr/{README,VERSION,{pkgconfig,config}_template,pkginfo} || die
+
+ dodir /usr/share
+ mv "${ED}"/usr/misc "${ED}"/usr/share/netpbm || die
+
+ doman userguide/*.[0-9]
+ dodoc README
+
+ cd doc || die
+ dodoc HISTORY USERDOC
+ docinto html
+ dodoc -r ../userguide/*.html
+}