summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-04-01 10:42:59 +0200
committerJames Le Cuirot <chewi@gentoo.org>2021-04-05 22:25:25 +0100
commit8fbda6c4cbe2e75f8882ac19653398deb27e0aa6 (patch)
tree1fe989a356d3422bd28487d0d97f0683566681ba /media-libs
parentfont-ebdftopcf.eclass: fix eclassdoc (diff)
downloadgentoo-8fbda6c4cbe2e75f8882ac19653398deb27e0aa6.tar.gz
gentoo-8fbda6c4cbe2e75f8882ac19653398deb27e0aa6.tar.bz2
gentoo-8fbda6c4cbe2e75f8882ac19653398deb27e0aa6.zip
media-libs/sdl2-image: CVE-2019-13616 _p20210328
Bug: https://bugs.gentoo.org/772194 Relevant patch is Fixed bug 4538 - validate image size when loading BMP files https://github.com/libsdl-org/SDL_image/commit/e12c931 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/20216 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sdl2-image/Manifest1
-rw-r--r--media-libs/sdl2-image/metadata.xml4
-rw-r--r--media-libs/sdl2-image/sdl2-image-2.0.5_p20210328.ebuild62
3 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/sdl2-image/Manifest b/media-libs/sdl2-image/Manifest
index 558bff0ce036..9819befb679f 100644
--- a/media-libs/sdl2-image/Manifest
+++ b/media-libs/sdl2-image/Manifest
@@ -1 +1,2 @@
DIST SDL2_image-2.0.5.tar.gz 11736518 BLAKE2B 8009fc4ff76d8f8f4093c02304329218e1d8b7d6fd9c747387f239bc6ee09133f8f3faee0005267ce29c083a6bf4ddcf8db72f502ea047f7288ec57ebbb16380 SHA512 77e743d3f32707e015b290c1379ae3c7d7a3fe265995713267f0d0ec6517de4808f0de9890b5ab28445941af5bc9fbff346620629e0d7d7e9f365262cab05ee7
+DIST SDL2_image-2.0.5_p20210328.tar.gz 12397062 BLAKE2B ae4fe8c30b21bc7dca87e2e78cab43c83e891630962eb020c29ba84c2b206bb749491dccddd8bcc212f2fd07da651691151baf41212fb5ea954427543e3bf994 SHA512 9ba0b671dedfb7bde072424cebfa7d65e79d2d58416833d84548777aff6bf0edda8dbe30c3e423bbb724f794b4b191e609b148f38573b4166eef31203ab0005d
diff --git a/media-libs/sdl2-image/metadata.xml b/media-libs/sdl2-image/metadata.xml
index a92c1a1c50db..a5e8d2d006ea 100644
--- a/media-libs/sdl2-image/metadata.xml
+++ b/media-libs/sdl2-image/metadata.xml
@@ -5,6 +5,10 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">libsdl-org/SDL_image</remote-id>
+ <bugs-to>https://github.com/libsdl-org/SDL_image/issues</bugs-to>
+ </upstream>
<use>
<flag name="webp">support loading WEBP images</flag>
</use>
diff --git a/media-libs/sdl2-image/sdl2-image-2.0.5_p20210328.ebuild b/media-libs/sdl2-image/sdl2-image-2.0.5_p20210328.ebuild
new file mode 100644
index 000000000000..fd36c4b51f1b
--- /dev/null
+++ b/media-libs/sdl2-image/sdl2-image-2.0.5_p20210328.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib multilib-minimal
+
+MY_P="SDL2_image-${PV}"
+MY_COMMIT="f36684864e82538da2d2cf57fa3db077a3be42c7"
+DESCRIPTION="Image file loading library"
+HOMEPAGE="https://www.libsdl.org/projects/SDL_image/"
+SRC_URI="https://github.com/libsdl-org/SDL_image/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.9[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:0[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0[${MULTILIB_USEDEP}] )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/SDL_image-${MY_COMMIT}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-sdltest
+ --enable-bmp
+ $(use_enable gif)
+ $(use_enable jpeg jpg)
+ --disable-jpg-shared
+ --enable-lbm
+ --enable-pcx
+ $(use_enable png)
+ --disable-png-shared
+ --enable-pnm
+ --enable-tga
+ $(use_enable tiff tif)
+ --disable-tif-shared
+ --enable-xcf
+ --enable-xpm
+ --enable-xv
+ $(use_enable webp)
+ --disable-webp-shared
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && newbin .libs/showimage$(get_exeext) showimage2$(get_exeext)
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ find "${ED}" -type f -name "*.la" -delete || die
+}