summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-30 23:46:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-30 23:47:04 +0200
commite9d0a0aa2be2a0430a66dd89b776d18cc63c393d (patch)
tree2fa9e572a72a0678972c3b280ec6b7e3481b439a /media-libs
parentdev-python/genshi: Add Python3 support by applying patches (diff)
downloadgentoo-e9d0a0aa2be2a0430a66dd89b776d18cc63c393d.tar.gz
gentoo-e9d0a0aa2be2a0430a66dd89b776d18cc63c393d.tar.bz2
gentoo-e9d0a0aa2be2a0430a66dd89b776d18cc63c393d.zip
media-libs/qimageblitz: Drop old
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch11
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6-r1.ebuild37
2 files changed, 0 insertions, 48 deletions
diff --git a/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch b/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
deleted file mode 100644
index 911c56b48ccb..000000000000
--- a/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur qimageblitz/blitz/asm_scale.S qimageblitz~/blitz/asm_scale.S
---- a/qimageblitz-orig/blitz/asm_scale.S 2007-10-17 01:17:57.000000000 +0200
-+++ b/qimageblitz/blitz/asm_scale.S 2007-10-17 01:19:12.000000000 +0200
-@@ -814,3 +814,7 @@
- SIZE(qimageScale_mmx_AARGBA)
-
- #endif
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6-r1.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6-r1.ebuild
deleted file mode 100644
index c3f31b3219fa..000000000000
--- a/media-libs/qimageblitz/qimageblitz-0.0.6-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="A graphical effect and filter library for KDE4"
-HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
-SRC_URI="mirror://kde/stable/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-KEYWORDS="hppa"
-SLOT="0"
-IUSE="cpu_flags_x86_3dnow altivec debug cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
-
-DEPEND="
- dev-qt/qtcore:4
- dev-qt/qtgui:4
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-9999-exec-stack.patch"
- "${FILESDIR}/${P}-gcc.patch"
-)
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_has cpu_flags_x86_3dnow 3dnow)
- $(cmake-utils_use_has altivec)
- $(cmake-utils_use_has cpu_flags_x86_mmx mmx)
- $(cmake-utils_use_has cpu_flags_x86_sse sse)
- $(cmake-utils_use_has cpu_flags_x86_sse2 sse2)
- )
- cmake-utils_src_configure
-}