summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-04 22:56:33 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-07 09:59:19 -0400
commitb6e47645fa97bd783240631a9292bd7cc7aa8ce9 (patch)
tree56bbc37323a78aa0f23367a10033ea87ebec93c4 /media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild
parentmedia-plugins/gst-plugins-ldac: Drop old versions (diff)
downloadgentoo-b6e47645fa97bd783240631a9292bd7cc7aa8ce9.tar.gz
gentoo-b6e47645fa97bd783240631a9292bd7cc7aa8ce9.tar.bz2
gentoo-b6e47645fa97bd783240631a9292bd7cc7aa8ce9.zip
media-plugins/gst-plugins-libav: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild')
-rw-r--r--media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild
deleted file mode 100644
index 052ca7b3eef2..000000000000
--- a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.16.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eapi7-ver multilib-minimal
-
-MY_PN="gst-libav"
-
-DESCRIPTION="FFmpeg based gstreamer plugin"
-HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
-SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="1.0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 x86"
-IUSE="+orc"
-
-RDEPEND="
- >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
- >=media-libs/gstreamer-${PV}:1.0[${MULTILIB_USEDEP}]
- >=media-libs/gst-plugins-base-${PV}:1.0[${MULTILIB_USEDEP}]
- >=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}]
- orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.12
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly
-
-PATCHES=(
- "${FILESDIR}"/external-ffmpeg4-dep.patch # Automatically rescan available elements for registry when system ffmpeg changes
-)
-
-multilib_src_configure() {
- GST_PLUGINS_BUILD=""
-
- ECONF_SOURCE=${S} \
- econf \
- --disable-maintainer-mode \
- --with-package-name="Gentoo GStreamer ebuild" \
- --with-package-origin="https://www.gentoo.org" \
- --disable-fatal-warnings \
- --with-system-libav \
- $(use_enable orc)
-}
-
-multilib_src_compile() {
- # Don't build with -Werror; verbose build
- emake ERROR_CFLAGS= V=1
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
-}