summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-11-02 11:16:36 +0530
committerMart Raudsepp <leio@gentoo.org>2022-11-20 18:12:28 +0000
commit99857f45011b1da80a5fc0ec73050dec67c65d35 (patch)
treeb65eb27a4f21bd0d77606696f383ff49c467bd9b /media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.20.4.ebuild
parentpackage.mask: Stop last rite of media-libs/libvisual for now (diff)
downloadgentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.gz
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.tar.bz2
gentoo-99857f45011b1da80a5fc0ec73050dec67c65d35.zip
media-libs/gstreamer: Version bump to 1.20.4
Closes: https://bugs.gentoo.org/877325 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28086 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.20.4.ebuild')
-rw-r--r--media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.20.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.20.4.ebuild b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.20.4.ebuild
new file mode 100644
index 000000000000..70efd94db894
--- /dev/null
+++ b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.20.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer-meson
+
+DESCRIPTION="X11 video capture stream plugin for GStreamer"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdamage-1.1.4-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+GST_PLUGINS_BUILD_DIR="ximage"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dximagesrc=enabled
+ -Dximagesrc-xshm=enabled
+ -Dximagesrc-xfixes=enabled
+ -Dximagesrc-xdamage=enabled
+ )
+
+ gstreamer_multilib_src_configure
+}