summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-11-03 09:53:27 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-03 09:53:39 +0100
commit2d250588a69485963151a67f966513e006e85d8d (patch)
treec8654a8a0476d21b3f4787f339e52561a371f4e2 /media-plugins
parentmail-filter/opendmarc-1.4.2: version bump (diff)
downloadgentoo-2d250588a69485963151a67f966513e006e85d8d.tar.gz
gentoo-2d250588a69485963151a67f966513e006e85d8d.tar.bz2
gentoo-2d250588a69485963151a67f966513e006e85d8d.zip
media-plugins/calf: bump to 0.9.4 + eapi8 + updated live
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/calf/Manifest1
-rw-r--r--media-plugins/calf/calf-0.90.4.ebuild82
-rw-r--r--media-plugins/calf/calf-9999.ebuild10
-rw-r--r--media-plugins/calf/files/calf-0.9.4-htmldir.patch (renamed from media-plugins/calf/files/calf-9999-htmldir.patch)0
-rw-r--r--media-plugins/calf/files/calf-0.9.4-no-automagic.patch (renamed from media-plugins/calf/files/calf-9999-no-automagic.patch)0
-rw-r--r--media-plugins/calf/files/calf-0.90.4-desktop.patch22
-rw-r--r--media-plugins/calf/files/calf-9999-desktop.patch14
7 files changed, 110 insertions, 19 deletions
diff --git a/media-plugins/calf/Manifest b/media-plugins/calf/Manifest
index c691c2aa9cda..08affd7f272d 100644
--- a/media-plugins/calf/Manifest
+++ b/media-plugins/calf/Manifest
@@ -1 +1,2 @@
DIST calf-0.90.3.tar.gz 15908050 BLAKE2B b3fff0232f6e0c70987108c5e12a47c606394acf010f1223275aa76472498cfda8e9ae82ccc6eae870225c05935a2c832817d8b1f9ade3f6c0ebc84aedfbfd33 SHA512 328a49f7c031e58b786bc1db5fa180f663d7910b2dfc781bccb2f3e0e2ab4158a1f62de96ef0b9e44cbedf778aaaedfb99a12b47dccddab739bf279001b3a1d7
+DIST calf-0.90.4.tar.gz 16119716 BLAKE2B 555a813c6e8d58ea67db349957d2673e614448e17a3e5e934106fa445d7a6c19bc739b2487a883c5e709ac8dd5f429363e3bea09d72c1ca23a5755ca3b765479 SHA512 666d699d989a588bfe9d1e92f6b221a30541c26874d5941f54c2b2f216d2a59d628f1579d1e789e4a40d07d06f43a31055ce67885abb25c032643aa5f75797cd
diff --git a/media-plugins/calf/calf-0.90.4.ebuild b/media-plugins/calf/calf-0.90.4.ebuild
new file mode 100644
index 000000000000..05e605bd370c
--- /dev/null
+++ b/media-plugins/calf/calf-0.90.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="A set of open source instruments and effects for digital audio workstations"
+HOMEPAGE="https://calf-studio-gear.org/"
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/calf-studio-gear/calf.git"
+else
+ SRC_URI="https://github.com/calf-studio-gear/calf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="cpu_flags_x86_sse experimental gtk jack lash lv2 static-libs"
+
+REQUIRED_USE="jack? ( gtk )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-libs/expat
+ dev-libs/glib:2
+ media-sound/fluidsynth:=
+ gtk? (
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.4-no-automagic.patch"
+ "${FILESDIR}/${PN}-0.9.4-htmldir.patch"
+ "${FILESDIR}/${PN}-0.90.4-desktop.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Upstream append -ffast-math by default, however since libtool links C++
+ # shared libs with -nostdlib, this causes symbol resolution error for
+ # __powidn2 when using compiler-rt. Disable fast math on compiler-rt until
+ # a better fix is found.
+ [[ $(tc-get-c-rtlib) = "compiler-rt" ]] && append-cxxflags "-fno-fast-math"
+
+ local myeconfargs=(
+ --prefix="${EPREFIX}"/usr
+ --without-obsolete-check
+ $(use_enable experimental)
+ $(use_enable gtk gui)
+ $(use_enable jack)
+ $(use_with lash)
+ $(use_with lv2 lv2)
+ $(usex lv2 "--with-lv2-dir=${EPREFIX}/usr/$(get_libdir)/lv2" "")
+ $(use_enable static-libs static)
+ $(use_enable cpu_flags_x86_sse sse)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/share/bash-completion/completions/calf \
+ "${ED}"/usr/share/bash-completion/completions/calfjackhost
+}
diff --git a/media-plugins/calf/calf-9999.ebuild b/media-plugins/calf/calf-9999.ebuild
index e3c5d724f4ca..05e605bd370c 100644
--- a/media-plugins/calf/calf-9999.ebuild
+++ b/media-plugins/calf/calf-9999.ebuild
@@ -13,7 +13,7 @@ if [[ "${PV}" = "9999" ]] ; then
EGIT_REPO_URI="https://github.com/calf-studio-gear/calf.git"
else
SRC_URI="https://github.com/calf-studio-gear/calf/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="LGPL-2.1"
@@ -43,9 +43,9 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${PN}-9999-no-automagic.patch"
- "${FILESDIR}/${PN}-9999-htmldir.patch"
- "${FILESDIR}/${PN}-9999-desktop.patch"
+ "${FILESDIR}/${PN}-0.9.4-no-automagic.patch"
+ "${FILESDIR}/${PN}-0.9.4-htmldir.patch"
+ "${FILESDIR}/${PN}-0.90.4-desktop.patch"
)
src_prepare() {
@@ -53,7 +53,7 @@ src_prepare() {
eautoreconf
}
-src_configure() {
+src_configure() {
# Upstream append -ffast-math by default, however since libtool links C++
# shared libs with -nostdlib, this causes symbol resolution error for
# __powidn2 when using compiler-rt. Disable fast math on compiler-rt until
diff --git a/media-plugins/calf/files/calf-9999-htmldir.patch b/media-plugins/calf/files/calf-0.9.4-htmldir.patch
index 4b6c77d42f83..4b6c77d42f83 100644
--- a/media-plugins/calf/files/calf-9999-htmldir.patch
+++ b/media-plugins/calf/files/calf-0.9.4-htmldir.patch
diff --git a/media-plugins/calf/files/calf-9999-no-automagic.patch b/media-plugins/calf/files/calf-0.9.4-no-automagic.patch
index 87fa8a7a18e3..87fa8a7a18e3 100644
--- a/media-plugins/calf/files/calf-9999-no-automagic.patch
+++ b/media-plugins/calf/files/calf-0.9.4-no-automagic.patch
diff --git a/media-plugins/calf/files/calf-0.90.4-desktop.patch b/media-plugins/calf/files/calf-0.90.4-desktop.patch
new file mode 100644
index 000000000000..4a761162e476
--- /dev/null
+++ b/media-plugins/calf/files/calf-0.90.4-desktop.patch
@@ -0,0 +1,22 @@
+ * QA Notice: This package installs one or more .desktop files that do not
+ * pass validation.
+ *
+ * /usr/share/applications/calf.desktop: error: value "0.90.1" for key "Version" in group "Desktop Entry" is not a known version
+ * /usr/share/applications/calf.desktop: warning: value "Application;AudioVideo;Audio;GNOME" for key "Categories" in group "Desktop Entry" contains a deprecated value "Application"
+
+
+
+--- a/calf.desktop.in
++++ b/calf.desktop.in
+@@ -1,10 +1,9 @@
+ [Desktop Entry]
+-Categories=Application;AudioVideo;Audio;GNOME
++Categories=AudioVideo;Audio;GNOME
+ Exec=calfjackhost
+ Icon=calf
+ Terminal=false
+ Type=Application
+-Version=@VERSION@
+
+ Name=Calf Plugin Pack for JACK
+ Name[fr]=Ensemble de greffons Calf pour JACK
diff --git a/media-plugins/calf/files/calf-9999-desktop.patch b/media-plugins/calf/files/calf-9999-desktop.patch
deleted file mode 100644
index 486007e7e06f..000000000000
--- a/media-plugins/calf/files/calf-9999-desktop.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/calf.desktop.in
-+++ b/calf.desktop.in
-@@ -1,10 +1,9 @@
- [Desktop Entry]
--Categories=Application;AudioVideo;Audio;GNOME
-+Categories=AudioVideo;Audio;GNOME
- Exec=calfjackhost
- Icon=calf
- Terminal=false
- Type=Application
--Version=@VERSION@
-
- Name=Calf Plugin Pack for JACK
- Name[fr]=Ensemble de greffons Calf pour JACK