summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2019-04-19 15:13:22 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2019-04-19 15:13:22 +0200
commit1682e283cc4c115fa66de0ef612287c4b979bf86 (patch)
tree8e250ebffe4ae3a4191dc926f478fe60a74eb6b7 /media-radio
parentmedia-radio/tucnak: Drop old (diff)
downloadgentoo-1682e283cc4c115fa66de0ef612287c4b979bf86.tar.gz
gentoo-1682e283cc4c115fa66de0ef612287c4b979bf86.tar.bz2
gentoo-1682e283cc4c115fa66de0ef612287c4b979bf86.zip
media-radio/tucnak: Version bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak/Manifest1
-rw-r--r--media-radio/tucnak/tucnak-4.16.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-radio/tucnak/Manifest b/media-radio/tucnak/Manifest
index da0793999d31..6b4fcbb3c32c 100644
--- a/media-radio/tucnak/Manifest
+++ b/media-radio/tucnak/Manifest
@@ -1,2 +1,3 @@
DIST tucnak-4.14.tar.gz 3514740 BLAKE2B f147eff8ef5a001309261b463c4334bdb82aedf5b262309336069592bff6473f93403c26b03470adc049cd337fac04eb5eed1f1eaf43414d023606d8bcbc0848 SHA512 f37895b08d302b71c345dc58df5590c3909edc8182047bd8b1a67218cc8159c9ab25b267adc6a05bd625d44dda3f21a45296611c91ce1cd974f95c6776552a49
DIST tucnak-4.15.tar.gz 3523096 BLAKE2B 38524dfee88511e2e31c0ba2302e8ced214285650b8069d953ef91420ea3c58ff4bc1026d843cefa0f6cc9de599dbd3216b54c17ad906151005352a903e3e195 SHA512 2bbe3d2dadd4f47848e559d26484bfc1cd0cf88d130330ba19a03b43be2b643a7245641c7185072285b5320af50ef1e3826089599e4b2c9f2d8331618016a862
+DIST tucnak-4.16.tar.gz 3526223 BLAKE2B 1e88157a2fc023cc115a9cadfffa7516eac2ff23e4fa5aef7d7f4a959899cf5d7be99a6d934eaee1c32c1b702ca5b5e37a82dd91b7ea03d7ac21815c2e8c0c63 SHA512 65547fd4f83d41bdf312d61c0b6d750c5f949399821c5298731ee6941de0bc95290e90a004c22d731319b0bbd7b55f0d512c2e616ebd43f0c35698cc940594ce
diff --git a/media-radio/tucnak/tucnak-4.16.ebuild b/media-radio/tucnak/tucnak-4.16.ebuild
new file mode 100644
index 000000000000..f97b30dca3c3
--- /dev/null
+++ b/media-radio/tucnak/tucnak-4.16.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic multilib
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw gpm hamlib suid"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libzia
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ # fix destop file
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
+ # fix doc install path
+ sed -i -e "s/docsdir/# docsdir/" \
+ -e "s/docs_DATA =/# docs_DATA/" \
+ -e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf $(use_with alsa) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}