summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-02-04 19:14:36 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2021-02-04 19:14:36 +0100
commit359b2cd8bd32574bf59dae8ecec5c958b9cc9e21 (patch)
treeb21e206d22a08798d198540c4a35ca1b92af7511 /media-radio
parentdev-libs/libzia: Version bump (diff)
downloadgentoo-359b2cd8bd32574bf59dae8ecec5c958b9cc9e21.tar.gz
gentoo-359b2cd8bd32574bf59dae8ecec5c958b9cc9e21.tar.bz2
gentoo-359b2cd8bd32574bf59dae8ecec5c958b9cc9e21.zip
media-radio/tucnak: Version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak/Manifest1
-rw-r--r--media-radio/tucnak/tucnak-4.25.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-radio/tucnak/Manifest b/media-radio/tucnak/Manifest
index 7d8730deaa69..f3363daf5e56 100644
--- a/media-radio/tucnak/Manifest
+++ b/media-radio/tucnak/Manifest
@@ -1,2 +1,3 @@
DIST tucnak-4.23.tar.gz 3550740 BLAKE2B 559f082e19dc22fb119ba6b075f83a49838347bde8856e22a90b9bfc66c8df17ef172967e0e6c4a88a3cfb7764ad36b6fe1a2dd18a9212d8c4637346a8616e7b SHA512 febd5daf943ec4428fe4d77542e20a47d69b017d345aff00ee7e0aca0cc287cf0f1abf3f858051e23aa8d0dffa4146b22fbdb5813d97debb902b91fd99dcd50a
DIST tucnak-4.24.tar.gz 3556553 BLAKE2B 78f75a6da859937fa36099f9adcb508065800e62d3ad5f9b21f294d86fe0b40f0384e7e15a35d3a0708f5516e117d29667a34653f00009f51ebb582923b993cd SHA512 5dbb129bc638b1f69dd159dd46237ceef1c830922266a663be0437e5f0fee612282a238315448aababb781950a8945f0e2ecf375eef61567291c07acc80526dd
+DIST tucnak-4.25.tar.gz 3588485 BLAKE2B ade2db19e3be9981d4c3813306e347f47df4e89d62a9b2c382f4b5ac04700850af40e63d8b4b13d7f7ae59f47c864c3af4a8fd7eb572919e4163b106da5d9ce8 SHA512 b9666877f322e3142dae6d95e65b7b1da7e14eac5517d11ae108bf96715205558697a80bb40faa20bf89a01385c30869c48aa8af197dd2c206b4bc8f8b5859b9
diff --git a/media-radio/tucnak/tucnak-4.25.ebuild b/media-radio/tucnak/tucnak-4.25.ebuild
new file mode 100644
index 000000000000..4bd49233408d
--- /dev/null
+++ b/media-radio/tucnak/tucnak-4.25.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic multilib
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw gpm hamlib suid"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libzia
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ # fix destop file
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
+ # fix doc install path
+ sed -i -e "s/docsdir/# docsdir/" \
+ -e "s/docs_DATA =/# docs_DATA/" \
+ -e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf $(use_with alsa) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}