summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/cdparanoia
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/cdparanoia')
-rw-r--r--media-sound/cdparanoia/Manifest2
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.10.2-r6.ebuild61
-rw-r--r--media-sound/cdparanoia/metadata.xml5
3 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/cdparanoia/Manifest b/media-sound/cdparanoia/Manifest
new file mode 100644
index 000000000000..3ce0ba518ca1
--- /dev/null
+++ b/media-sound/cdparanoia/Manifest
@@ -0,0 +1,2 @@
+DIST cdparanoia-III-10.2-patches-2.tbz2 6242 SHA256 3c06fa469d7d7774e1c168b4a79851f50aeb6a4054a515ce4e30ef5ed83d1fbc SHA512 523a9ef9f3de263236aad6da102b807a6620cde8767e297e54dcd552f59077d959a89187bc82ad71c577fa66c4862d7c651e922b8b8b8369dd63685cbda9cb74 WHIRLPOOL 238b8aed5edab02350263455b7205531a8cf830fdb5f8d3d8245756bd712295d8d32c17f53518fc8410112d6b1adb377e6eb3658a3649e0df7a9bd7ed3227269
+DIST cdparanoia-III-10.2.src.tgz 183236 SHA256 005db45ef4ee017f5c32ec124f913a0546e77014266c6a1c50df902a55fe64df SHA512 4ab0a0f5ef44d56c1af72d1fc1035566a1a89c4eeddb9e8baea675fe51c06138d913342afc8bed167d9fa55672fa25a2763ce21f7e24c1232e4739aff20733a7 WHIRLPOOL fe0c211ce42c58534978669bc1d9c63de7cba6dcd8fbfe6d6c78fc1d2600680c5a94e52e5552c8423f1929a070b2bba35c6921a7c7ddb8921a6ebd9127dacb60
diff --git a/media-sound/cdparanoia/cdparanoia-3.10.2-r6.ebuild b/media-sound/cdparanoia/cdparanoia-3.10.2-r6.ebuild
new file mode 100644
index 000000000000..d17ff69dd2c6
--- /dev/null
+++ b/media-sound/cdparanoia/cdparanoia-3.10.2-r6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils libtool toolchain-funcs versionator multilib-minimal
+
+MY_P=${PN}-III-$(get_version_component_range 2-3)
+DESCRIPTION="an advanced CDDA reader with error correction"
+HOMEPAGE="http://www.xiph.org/paranoia"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${MY_P}.src.tgz
+ http://dev.gentoo.org/~ssuominen/${MY_P}-patches-2.tbz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-eselect/eselect-cdparanoia
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r4
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
+
+ mv configure.guess config.guess
+ mv configure.sub config.sub
+
+ sed -i -e '/configure.\(guess\|sub\)/d' configure.in || die
+
+ eautoconf
+ elibtoolize
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export AR CC RANLIB
+ econf
+}
+
+multilib_src_compile() {
+ emake OPT="${CFLAGS} -I${S}/interface"
+ use static-libs && emake lib OPT="${CFLAGS} -I${S}/interface"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/${PN}{,-paranoia}
+}
+
+pkg_postinst() {
+ eselect ${PN} update ifunset
+}
+
+pkg_postrm() {
+ eselect ${PN} update ifunset
+}
diff --git a/media-sound/cdparanoia/metadata.xml b/media-sound/cdparanoia/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-sound/cdparanoia/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>