summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2020-01-10 00:29:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-16 14:41:30 +0100
commitcf36947cb83d55e687b318bb04fdff1c59ab737c (patch)
tree45127c8036dba093dc72c4b7864b556c90662938 /media-sound/frescobaldi
parentprofiles: Mask kde-misc/kwebkitpart for removal (diff)
downloadgentoo-cf36947cb83d55e687b318bb04fdff1c59ab737c.tar.gz
gentoo-cf36947cb83d55e687b318bb04fdff1c59ab737c.tar.bz2
gentoo-cf36947cb83d55e687b318bb04fdff1c59ab737c.zip
media-sound/frescobaldi: version bump to 3.1.1
Also depend on dev-python/PyQtWebEngine instead of dev-python/PyQt5[webkit] Closes: https://bugs.gentoo.org/704876 Signed-off-by: Jouni Kosonen <jouni.kosonen@tukesoft.com> Closes: https://github.com/gentoo/gentoo/pull/14290 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/frescobaldi')
-rw-r--r--media-sound/frescobaldi/Manifest1
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.1.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/Manifest b/media-sound/frescobaldi/Manifest
index 4bc5e97ad2f2..47d955fa9499 100644
--- a/media-sound/frescobaldi/Manifest
+++ b/media-sound/frescobaldi/Manifest
@@ -1 +1,2 @@
DIST frescobaldi-3.0.0.tar.gz 4895317 BLAKE2B 6a9a2b92d075742f54b3148761f1946c4dd73616482aec9278c0326d5597773ce6eb714f8d31d49f79051294d23d4e43552ce29bde0f464d1a677900b8a276f6 SHA512 e33cbcb70bec74239cd84691725e9978b6c6fee391848c7de8ea32dd5459d953ddda120eeea25a602154d94a84947b6c151237b859450162db0822ef58fd7787
+DIST frescobaldi-3.1.1.tar.gz 6244496 BLAKE2B 0687a608c773d3295197ea7ef117fa099acc2dfcd2de0f7e7ed69ff6ab643007d631f9e3abc1509163503473cc2d95f7cfe7ca87a5d636a796490af8479b8db0 SHA512 b4f65bdbcb5ed1c9837b84f9721b166dbac3d5ed12d03521d91d9f4660ff61af951209071ceae07158da3ad9f7c7152924a4f5ce87deedc8d90decf4b4efa86d
diff --git a/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild b/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild
new file mode 100644
index 000000000000..36c28099f62e
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ >=dev-python/python-ly-0.9.4[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}