summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2024-01-03 15:32:26 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-05 11:32:53 +0100
commitb1d7684da16b55f8e0f3b9283e757167b399951b (patch)
tree68649b7ec1bd1d6bda68140af5a59aefaca1db5b /media-sound/guitarix
parentdev-java/bsf: move dependencies to runtime classpath (diff)
downloadgentoo-b1d7684da16b55f8e0f3b9283e757167b399951b.tar.gz
gentoo-b1d7684da16b55f8e0f3b9283e757167b399951b.tar.bz2
gentoo-b1d7684da16b55f8e0f3b9283e757167b399951b.zip
media-sound/guitarix: restore parallel build
Build system messes with the build jobs count, so that waf build always respects the number of jobs passed to waf configure. And since waf-utils eclass passes --jobs=1 to waf configure, we are always building using only 1 job. Pass --jobs with the correct number of jobs to waf configure as a workaround. Closes: https://bugs.gentoo.org/908690 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/34639 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/files/guitarix-0.44.1-py3.11.patch (renamed from media-sound/guitarix/files/guitarix-0.41.0-py3.11.patch)0
-rw-r--r--media-sound/guitarix/guitarix-0.44.1.ebuild7
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild3
3 files changed, 6 insertions, 4 deletions
diff --git a/media-sound/guitarix/files/guitarix-0.41.0-py3.11.patch b/media-sound/guitarix/files/guitarix-0.44.1-py3.11.patch
index f419c2ed7ce7..f419c2ed7ce7 100644
--- a/media-sound/guitarix/files/guitarix-0.41.0-py3.11.patch
+++ b/media-sound/guitarix/files/guitarix-0.44.1-py3.11.patch
diff --git a/media-sound/guitarix/guitarix-0.44.1.ebuild b/media-sound/guitarix/guitarix-0.44.1.ebuild
index 60b76beb379f..7296f64747af 100644
--- a/media-sound/guitarix/guitarix-0.44.1.ebuild
+++ b/media-sound/guitarix/guitarix-0.44.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE='threads(+)'
-inherit python-any-r1 waf-utils xdg
+inherit multiprocessing python-any-r1 waf-utils xdg
DESCRIPTION="Virtual guitar amplifier for Linux"
HOMEPAGE="https://guitarix.org/"
@@ -63,8 +63,8 @@ DOCS=( changelog README )
PATCHES=(
"${FILESDIR}"/${PN}-0.41.0-nostrip.patch
- "${FILESDIR}"/${PN}-0.41.0-py3.11.patch
- "${FILESDIR}"/${PN}-0.44.1-zita-resampler-1.10.patch
+ "${FILESDIR}"/${P}-py3.11.patch
+ "${FILESDIR}"/${P}-zita-resampler-1.10.patch
"${FILESDIR}"/${P}-gcc-13.patch
)
@@ -82,6 +82,7 @@ src_configure() {
--no-faust
--no-ldconfig
--shared-lib
+ --jobs=$(makeopts_jobs)
$(use_enable nls)
$(usex bluetooth "" "--no-bluez")
$(usex debug "--debug" "")
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
index ed2429d53f6d..490d308775b1 100644
--- a/media-sound/guitarix/guitarix-9999.ebuild
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -9,7 +9,7 @@ PYTHON_REQ_USE='threads(+)'
EGIT_OVERRIDE_REPO_ENYOJS_BOOTPLATE="https://github.com/enyojs/bootplate.git"
EGIT_OVERRIDE_BRANCH_ENYOJS_BOOTPLATE="master"
-inherit python-any-r1 waf-utils xdg git-r3
+inherit multiprocessing python-any-r1 waf-utils xdg git-r3
DESCRIPTION="Virtual guitar amplifier for Linux"
HOMEPAGE="https://guitarix.org/"
@@ -79,6 +79,7 @@ src_configure() {
--no-faust
--no-ldconfig
--shared-lib
+ --jobs=$(makeopts_jobs)
$(use_enable nls)
$(usex bluetooth "" "--no-bluez")
$(usex debug "--debug" "")