summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/nted/nted-1.10.18-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/nted/nted-1.10.18-r3.ebuild')
-rw-r--r--media-sound/nted/nted-1.10.18-r3.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/nted/nted-1.10.18-r3.ebuild b/media-sound/nted/nted-1.10.18-r3.ebuild
new file mode 100644
index 000000000000..495a5d2254ae
--- /dev/null
+++ b/media-sound/nted/nted-1.10.18-r3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="WYSIWYG score editor for GTK+"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2 NTED_FONT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc debug nls"
+
+RDEPEND="
+ >=dev-libs/glib-2:2
+ media-libs/alsa-lib
+ >=media-libs/freetype-2.5.1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( ABOUT_THE_EXAMPLES.TXT AUTHORS FAQ README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc47.patch" # bug #424291
+ "${FILESDIR}/${P}-lilypond.patch" # bug #437540
+ "${FILESDIR}/${P}-lilypond-tremolo.patch" # bug #437540
+ "${FILESDIR}/${P}-automake-1.12.patch" # bug #459466
+ "${FILESDIR}/${P}-freetype.patch" # bug #514522
+)
+
+src_prepare() {
+ # fix desktop file, wrt bug #458080
+ sed -i \
+ -e 's/nted.png/nted/' \
+ -e '/^Categories/s/Application;//' \
+ datafiles/applications/nted.desktop || die 'sed on desktop file failed'
+ # drop -g from CXXFLAGS, wrt bug #458086
+ sed -i -e '/CXXFLAGS/s/ -g//' configure.in || die 'sed on configure.in failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Trick ./configure to believe we have gnome-extra/yelp installed.
+ has_version gnome-extra/yelp || export ac_cv_path_YELP="$(type -P true)"
+
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_with doc)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ # respect AR, wrt bug #458084
+ autotools-utils_src_compile AR="$(tc-getAR)"
+}