summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 00:48:58 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 00:48:58 +0100
commit0a974963abe38bdf75897266c595c501cd32ee20 (patch)
tree8aad4136212adb91c25f7713cfa4020fcbd86b5b /media-sound/ttaenc/files
parentmedia-sound/gimmix: Port to EAPI 7 (diff)
downloadgentoo-0a974963abe38bdf75897266c595c501cd32ee20.tar.gz
gentoo-0a974963abe38bdf75897266c595c501cd32ee20.tar.bz2
gentoo-0a974963abe38bdf75897266c595c501cd32ee20.zip
media-sound/ttaenc: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/ttaenc/files')
-rw-r--r--media-sound/ttaenc/files/ttaenc-3.4.1-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-sound/ttaenc/files/ttaenc-3.4.1-fix-build-system.patch b/media-sound/ttaenc/files/ttaenc-3.4.1-fix-build-system.patch
new file mode 100644
index 000000000000..794316d24899
--- /dev/null
+++ b/media-sound/ttaenc/files/ttaenc-3.4.1-fix-build-system.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,16 +2,12 @@
+ # $Id: Makefile,v 1.4 2007/04/04 00:00:00 root Exp $
+ #
+
+-CFLAGS = -Wall -O3 -fomit-frame-pointer -funroll-loops \
+- -fforce-addr -falign-functions=4 -msse
++CFLAGS += -Wall
+ TTAENC = ttaenc
+ INSDIR = /usr/bin
+
+ ttaenc: $(patsubst %.c, %.o, $(wildcard *.c))
+- gcc $^ -o $@ $(CFLAGS)
+-
+-%.o: %.c
+- gcc -c $(CFLAGS) $<
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+ install:
+ [ -d "$(INSDIR)" ] || mkdir $(INSDIR)