summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-03 07:41:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-03 07:51:22 -0400
commit3e03e409f8d2cb9fb3114e7d9e7cfd3e55d5a471 (patch)
tree379798d90fd0bcadffee0b680a71fcd558930e56 /media-sound/xmms2
parentdev-python/pytest-xvfb: enable py3.13 (diff)
downloadgentoo-3e03e409f8d2cb9fb3114e7d9e7cfd3e55d5a471.tar.gz
gentoo-3e03e409f8d2cb9fb3114e7d9e7cfd3e55d5a471.tar.bz2
gentoo-3e03e409f8d2cb9fb3114e7d9e7cfd3e55d5a471.zip
media-sound/xmms2: enable py3.13
Unknown if bindings are ok given we have no xmms2 python client packaged, USE=python serve no purpose right now. More importantly waf and building seems fine with 3.13. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-sound/xmms2')
-rw-r--r--media-sound/xmms2/xmms2-0.9.3-r1.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/media-sound/xmms2/xmms2-0.9.3-r1.ebuild b/media-sound/xmms2/xmms2-0.9.3-r1.ebuild
index a466553f269a..eda60ca94541 100644
--- a/media-sound/xmms2/xmms2-0.9.3-r1.ebuild
+++ b/media-sound/xmms2/xmms2-0.9.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic optfeature perl-functions python-single-r1 waf-utils
@@ -36,10 +36,12 @@ XMMS2_PLUGINS=(
IUSE="
${XMMS2_OPTIONALS[@]%:*}
${XMMS2_PLUGINS[@]%:*}
- +server"
+ +server
+"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
- test? ( server )"
+ test? ( server )
+"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -96,7 +98,8 @@ COMMON_DEPEND="
net-dns/avahi[mdnsresponder-compat]
net-misc/curl
)
- )"
+ )
+"
RDEPEND="
${COMMON_DEPEND}
perl? (
@@ -109,16 +112,19 @@ RDEPEND="
python? (
${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
- )"
+ )
+"
DEPEND="
${COMMON_DEPEND}
cxx? ( dev-libs/boost )
- test? ( dev-util/cunit )"
+ test? ( dev-util/cunit )
+"
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
perl? ( dev-perl/Pod-Parser )
- python? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]') )"
+ python? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]') )
+"
QA_CONFIG_IMPL_DECL_SKIP=(
avcodec_free_frame # succcessfully detects that this is gone in newer ffmpeg