summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-15 17:00:12 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-15 17:24:50 -0500
commit06f462555fe7acf69ec61ed98a437cc74530e203 (patch)
tree9d69099fca5c7561c24126f2cf3629a844754e0b /media-sound
parentmedia-sound/cava: add 0.10.3 (diff)
downloadgentoo-06f462555fe7acf69ec61ed98a437cc74530e203.tar.gz
gentoo-06f462555fe7acf69ec61ed98a437cc74530e203.tar.bz2
gentoo-06f462555fe7acf69ec61ed98a437cc74530e203.zip
media-sound/cava: add bounds for broken autoconf-archive
Was trying to bump this and had kind of forgot this still was neither fixed nor masked downstream, so limit the version (and allow the next one by assuming that this will be fixed so that this will not need further attention/revbump). Closes: https://bugs.gentoo.org/941845 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cava/cava-0.10.2.ebuild12
-rw-r--r--media-sound/cava/cava-0.10.3.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/media-sound/cava/cava-0.10.2.ebuild b/media-sound/cava/cava-0.10.2.ebuild
index 799f0d561c41..e3538ad7031b 100644
--- a/media-sound/cava/cava-0.10.2.ebuild
+++ b/media-sound/cava/cava-0.10.2.ebuild
@@ -33,9 +33,15 @@ RDEPEND="
sndio? ( media-sound/sndio:= )
"
DEPEND="${RDEPEND}"
+# bug #941845 wrt autoconf-archive bounds
BDEPEND="
virtual/pkgconfig
- sdl? ( dev-build/autoconf-archive )
+ sdl? (
+ || (
+ >dev-build/autoconf-archive-2024.10.16
+ <dev-build/autoconf-archive-2024.10.16
+ )
+ )
"
src_prepare() {
@@ -46,6 +52,10 @@ src_prepare() {
default
+ # TODO: drop this when autoconf-archive is fixed (bug #941845), this is
+ # to handle the USE=-sdl case given it breaks it present
+ use sdl || sed -i 's/AX_CHECK_GL/&_DISABLED/' configure.ac || die
+
echo ${PV} > version || die
eautoreconf
}
diff --git a/media-sound/cava/cava-0.10.3.ebuild b/media-sound/cava/cava-0.10.3.ebuild
index 92919781923f..dd7afa40f2d0 100644
--- a/media-sound/cava/cava-0.10.3.ebuild
+++ b/media-sound/cava/cava-0.10.3.ebuild
@@ -33,9 +33,15 @@ RDEPEND="
sndio? ( media-sound/sndio:= )
"
DEPEND="${RDEPEND}"
+# bug #941845 wrt autoconf-archive bounds
BDEPEND="
virtual/pkgconfig
- sdl? ( dev-build/autoconf-archive )
+ sdl? (
+ || (
+ >dev-build/autoconf-archive-2024.10.16
+ <dev-build/autoconf-archive-2024.10.16
+ )
+ )
"
src_prepare() {
@@ -49,6 +55,10 @@ src_prepare() {
default
+ # TODO: drop this when autoconf-archive is fixed (bug #941845), this is
+ # to handle the USE=-sdl case given it breaks it present
+ use sdl || sed -i 's/AX_CHECK_GL/&_DISABLED/' configure.ac || die
+
# respect both ESYSROOT+slotting (can't use CPPFLAGS, comes before)
sed -i "s|/usr/include/iniparser|${ESYSROOT}&${inip} |" configure.ac || die