summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-03-25 11:48:33 +0000
committerMarek Szuba <marecki@gentoo.org>2024-03-25 11:56:13 +0000
commit13c72cf49ff606199727afd0b2266bc90c1ce19b (patch)
treed7e138007cbf282a3eb35689cec6b7176633ab23 /media-sound
parentdev-games/mygui: remove -Werror (diff)
downloadgentoo-13c72cf49ff606199727afd0b2266bc90c1ce19b.tar.gz
gentoo-13c72cf49ff606199727afd0b2266bc90c1ce19b.tar.bz2
gentoo-13c72cf49ff606199727afd0b2266bc90c1ce19b.zip
media-sound/linux-show-player: add 0.6.1
Closes: https://bugs.gentoo.org/926597 Closes: https://bugs.gentoo.org/926864 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/linux-show-player/Manifest1
-rw-r--r--media-sound/linux-show-player/linux-show-player-0.6.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/linux-show-player/Manifest b/media-sound/linux-show-player/Manifest
index 3815d8daccdb..e11bb84e9f0e 100644
--- a/media-sound/linux-show-player/Manifest
+++ b/media-sound/linux-show-player/Manifest
@@ -1 +1,2 @@
DIST linux-show-player-0.5.3.tar.gz 1080409 BLAKE2B 8292263965434587b0086c6505167a1a3dbe82593a07a7c26855136f8c330ffd1c16ecd1e7e758af7e07731df7db79a66743297d22594d9332025e73a7990c34 SHA512 f60f65c045fb57c2c2e5f2daf6b225115a0f4fef173869e971741f2e40b71931b88e56c2343c348701784449d1f032219d307cdb7bb31d6283ea2b0c816d0286
+DIST linux-show-player-0.6.1.tar.gz 1955112 BLAKE2B c655aac4f83653c96b728ca8d0a249343697fb98ba1fb885220d300ab08d71c564f06a355d67c9d920654a3c7388876ef57eaa4538fe5a70b0395e590a061961 SHA512 7bab76b3f9bf354479a57d0bc4492c6f47e93a05692b878aa8ee6aa025cdb97f2c2a84b88c70fc1d88f5742b614a5d283afa6397c57612bcd6b0828b67a71042
diff --git a/media-sound/linux-show-player/linux-show-player-0.6.1.ebuild b/media-sound/linux-show-player/linux-show-player-0.6.1.ebuild
new file mode 100644
index 000000000000..a70843e858f4
--- /dev/null
+++ b/media-sound/linux-show-player/linux-show-player-0.6.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by pyalsa: https://github.com/alsa-project/alsa-python/issues/8
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="A cue player designed for stage productions"
+HOMEPAGE="https://www.linux-show-player.org/ https://github.com/FrancescoCeruti/linux-show-player/"
+SRC_URI="https://github.com/FrancescoCeruti/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa jack midi pulseaudio timecode"
+
+# TODO:
+# - network mode - falcon not packaged (QA issues, several unpackaged test dependencies)
+# - Open Sound Control support - pyliblo3 not packaged (last release in 2021, fails to build against modern cython)
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+ ')
+ media-libs/gstreamer[introspection]
+ alsa? (
+ $(python_gen_cond_dep '
+ dev-python/pyalsa[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base[alsa]
+ )
+ jack? (
+ $(python_gen_cond_dep '
+ dev-python/jack-client[${PYTHON_USEDEP}]
+ ')
+ media-plugins/gst-plugins-jack
+ )
+ midi? (
+ $(python_gen_cond_dep '
+ dev-python/mido[rtmidi,${PYTHON_USEDEP}]
+ ')
+ )
+ pulseaudio? ( media-plugins/gst-plugins-pulse )
+ timecode? (
+ app-misc/ola[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "${PN} uses GStreamer as its audio back-end so make sure you have plug-ins installed for all the audio formats you want to use"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 0.6.0; then
+ ewarn "Please be warned that current versions of ${PN} *cannot* open 0.5.x save files."
+ ewarn "Unfortunately upstream has provided no workaround for this."
+ ewarn
+ break
+ fi
+ done
+ fi
+
+ if use timecode; then
+ elog "Remember to start an OLA session on your computer if you want ${PN} to send timecodes"
+ fi
+}