summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-06-08 09:01:00 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-08 09:01:17 +0200
commitd0160ddea690d92046775e581b0062f12edb0a85 (patch)
tree00a4c65f0d70eb42efcdbbd08f1b455ad81d58bd /media-sound
parentdev-python/pytest-reserial: Stabilize 0.4.1 ALLARCHES, #933806 (diff)
downloadgentoo-d0160ddea690d92046775e581b0062f12edb0a85.tar.gz
gentoo-d0160ddea690d92046775e581b0062f12edb0a85.tar.bz2
gentoo-d0160ddea690d92046775e581b0062f12edb0a85.zip
media-sound/cadence: added python 3.12 + some adjustments
sync'd live ebuild with the versioned one remove non-existant alternative dependency added remote-id and reformatted metadata.xml Closes: https://bugs.gentoo.org/929654 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cadence/cadence-0.9.2-r1.ebuild9
-rw-r--r--media-sound/cadence/cadence-9999.ebuild27
-rw-r--r--media-sound/cadence/metadata.xml17
3 files changed, 30 insertions, 23 deletions
diff --git a/media-sound/cadence/cadence-0.9.2-r1.ebuild b/media-sound/cadence/cadence-0.9.2-r1.ebuild
index 45f90c398df0..267bf2c07c73 100644
--- a/media-sound/cadence/cadence-0.9.2-r1.ebuild
+++ b/media-sound/cadence/cadence-0.9.2-r1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit python-single-r1 xdg desktop
DESCRIPTION="Collection of tools useful for audio production"
HOMEPAGE="https://kx.studio//Applications:Cadence"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/falkTX/Cadence.git"
else
@@ -36,9 +36,8 @@ CDEPEND="
a2jmidid? ( media-sound/a2jmidid[dbus] )
pulseaudio? (
|| (
- media-sound/pulseaudio-daemon[jack]
media-video/pipewire[jack-sdk]
- <media-sound/pulseaudio-15.99.1[daemon(+),jack]
+ media-sound/pulseaudio-daemon[jack]
)
)"
RDEPEND="${CDEPEND}"
diff --git a/media-sound/cadence/cadence-9999.ebuild b/media-sound/cadence/cadence-9999.ebuild
index 84dc5764486e..def22af01490 100644
--- a/media-sound/cadence/cadence-9999.ebuild
+++ b/media-sound/cadence/cadence-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit python-single-r1 xdg desktop
DESCRIPTION="Collection of tools useful for audio production"
@@ -24,7 +24,8 @@ IUSE="a2jmidid pulseaudio opengl"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+CDEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/PyQt5[dbus,gui,opengl?,svg,widgets,${PYTHON_USEDEP}]
@@ -32,14 +33,18 @@ RDEPEND="${PYTHON_DEPS}
media-sound/jack_capture
virtual/jack
a2jmidid? ( media-sound/a2jmidid[dbus] )
- pulseaudio? ( || (
- media-video/pipewire[jack-sdk]
- media-sound/pulseaudio-daemon[jack]
- ) )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.9.1-fix-clang.patch )
+ pulseaudio? (
+ || (
+ media-video/pipewire[jack-sdk]
+ media-sound/pulseaudio-daemon[jack]
+ )
+ )"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.1-fix-clang.patch
+)
src_prepare() {
sed -i -e "s/python3/${EPYTHON}/" \
diff --git a/media-sound/cadence/metadata.xml b/media-sound/cadence/metadata.xml
index 2545a82c827c..56363a93c093 100644
--- a/media-sound/cadence/metadata.xml
+++ b/media-sound/cadence/metadata.xml
@@ -1,11 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>proaudio@gentoo.org</email>
- <name>Gentoo ProAudio Project</name>
-</maintainer>
-<use>
- <flag name="a2jmidid">Enables support for legacy ALSA sequencer applications in JACK MIDI system</flag>
-</use>
+ <maintainer type="project">
+ <email>proaudio@gentoo.org</email>
+ <name>Gentoo ProAudio Project</name>
+ </maintainer>
+ <use>
+ <flag name="a2jmidid">Enables support for legacy ALSA sequencer applications in JACK MIDI system</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">falkTX/Cadence</remote-id>
+ </upstream>
</pkgmetadata>