summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/v4l-dvb-saa716x/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/v4l-dvb-saa716x/files')
-rw-r--r--media-tv/v4l-dvb-saa716x/files/OSD_RAW_CMD_patch_2.diff27
-rw-r--r--media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-3.19-set_gpio.patch24
-rw-r--r--media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-Makefilepatch-2.diff8
3 files changed, 59 insertions, 0 deletions
diff --git a/media-tv/v4l-dvb-saa716x/files/OSD_RAW_CMD_patch_2.diff b/media-tv/v4l-dvb-saa716x/files/OSD_RAW_CMD_patch_2.diff
new file mode 100644
index 000000000000..7f09a1d60f1a
--- /dev/null
+++ b/media-tv/v4l-dvb-saa716x/files/OSD_RAW_CMD_patch_2.diff
@@ -0,0 +1,27 @@
+--- linux/drivers/media/common/saa716x/saa716x_ff_cmd.h.orig 2011-11-12 14:46:51.175700236 +0100
++++ linux/drivers/media/common/saa716x/saa716x_ff_cmd.h 2011-11-12 14:45:10.103702959 +0100
+@@ -1,6 +1,24 @@
+ #ifndef __SAA716x_FF_CMD_H
+ #define __SAA716x_FF_CMD_H
+
++#if !defined OSD_RAW_CMD
++typedef struct osd_raw_cmd_s {
++ const void *cmd_data;
++ int cmd_len;
++ void *result_data;
++ int result_len;
++} osd_raw_cmd_t;
++
++typedef struct osd_raw_data_s {
++ const void *data_buffer;
++ int data_length;
++ int data_handle;
++} osd_raw_data_t;
++
++#define OSD_RAW_CMD _IOWR('o', 162, osd_raw_cmd_t)
++#define OSD_RAW_DATA _IOWR('o', 163, osd_raw_data_t)
++#endif
++
+ extern int sti7109_cmd_init(struct sti7109_dev *sti7109);
+ extern int sti7109_raw_cmd(struct sti7109_dev * sti7109,
+ osd_raw_cmd_t * cmd);
diff --git a/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-3.19-set_gpio.patch b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-3.19-set_gpio.patch
new file mode 100644
index 000000000000..895caa4449e0
--- /dev/null
+++ b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-3.19-set_gpio.patch
@@ -0,0 +1,24 @@
+--- v4l-dvb-saa716x-d7e98fc59230-orig/linux/drivers/media/common/saa716x/saa716x_budget.c 2014-11-09 15:44:55.000000000 +0100
++++ v4l-dvb-saa716x-d7e98fc59230/linux/drivers/media/common/saa716x/saa716x_budget.c 2015-02-28 13:58:01.258743639 +0100
+@@ -497,10 +497,10 @@
+ break;
+ }
+
+- err = stv090x_set_gpio(fe, 2, 0, en, 0);
++ err = skystar2_stv090x_config.set_gpio(fe, 2, 0, en, 0);
+ if (err < 0)
+ goto exit;
+- err = stv090x_set_gpio(fe, 3, 0, sel, 0);
++ err = skystar2_stv090x_config.set_gpio(fe, 3, 0, sel, 0);
+ if (err < 0)
+ goto exit;
+
+@@ -519,7 +519,7 @@
+ else
+ value = 0;
+
+- err = stv090x_set_gpio(fe, 4, 0, value, 0);
++ err = skystar2_stv090x_config.set_gpio(fe, 4, 0, value, 0);
+ if (err < 0)
+ goto exit;
+
diff --git a/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-Makefilepatch-2.diff b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-Makefilepatch-2.diff
new file mode 100644
index 000000000000..78ba021fb4fe
--- /dev/null
+++ b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-Makefilepatch-2.diff
@@ -0,0 +1,8 @@
+--- v4l-dvb-saa716x-cfa4b4faab67/linux/drivers/media/common/saa716x/Makefile.orig 2013-03-02 07:44:51.112642592 +0100
++++ v4l-dvb-saa716x-cfa4b4faab67/linux/drivers/media/common/saa716x/Makefile 2013-03-02 07:46:56.703138542 +0100
+@@ -24,3 +24,5 @@
+ obj-$(CONFIG_DVB_SAA716X_FF) += saa716x_ff.o
+
+ EXTRA_CFLAGS = -Idrivers/media/dvb/dvb-core/ -Idrivers/media/dvb/frontends/ -Idrivers/media/dvb-core/ -Idrivers/media/dvb-frontends/
++EXTRA_CFLAGS += -Idrivers/media/common/tuners/ # up to kernel 3.6
++EXTRA_CFLAGS += -Idrivers/media/tuners/ # kernel 3.7+