summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Steward <cstew764@gmail.com>2020-01-03 17:55:09 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-21 20:10:49 +0100
commit2329d32b35d5cb7bf4f472f2536b922dca3270f8 (patch)
tree4749e93c16255fa619a99e75b03f869e780bcac2 /media-video/baka-mplayer/baka-mplayer-9999.ebuild
parentmedia-video/baka-mplayer: fix mpv >=0.23.0 support (diff)
downloadgentoo-2329d32b35d5cb7bf4f472f2536b922dca3270f8.tar.gz
gentoo-2329d32b35d5cb7bf4f472f2536b922dca3270f8.tar.bz2
gentoo-2329d32b35d5cb7bf4f472f2536b922dca3270f8.zip
media-video/baka-mplayer: QA fix for xdg icon cache update
Simple fix of QA issue reported by emerge, where xdg_icon_cache_update() has to be called after installing and after removing. Signed-off-by: Christopher Steward <cstew764@gmail.com> Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/baka-mplayer/baka-mplayer-9999.ebuild')
-rw-r--r--media-video/baka-mplayer/baka-mplayer-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/media-video/baka-mplayer/baka-mplayer-9999.ebuild b/media-video/baka-mplayer/baka-mplayer-9999.ebuild
index 73e27a96b7cc..1351f8663d3e 100644
--- a/media-video/baka-mplayer/baka-mplayer-9999.ebuild
+++ b/media-video/baka-mplayer/baka-mplayer-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit qmake-utils git-r3
+inherit qmake-utils git-r3 xdg-utils
DESCRIPTION="Cross-platform libmpv-based multimedia player with uncluttered design"
HOMEPAGE="http://bakamplayer.u8sand.net/"
@@ -18,7 +18,8 @@ BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig"
-RDEPEND="dev-qt/qtcore:5
+RDEPEND="
+ dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
@@ -46,3 +47,11 @@ src_configure() {
lupdate="$(qt5_get_bindir)"/lupdate \
src/Baka-MPlayer.pro
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}