summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 22:32:52 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 22:33:23 +0200
commit862ca1738ccf75e258934ba641d4bdb98f0d2a44 (patch)
treeabd371d43607dbd484c017906e9271815b600d9a /media-video/vdr
parentwww-servers/gatling: remove libressl support (diff)
downloadgentoo-862ca1738ccf75e258934ba641d4bdb98f0d2a44.tar.gz
gentoo-862ca1738ccf75e258934ba641d4bdb98f0d2a44.tar.bz2
gentoo-862ca1738ccf75e258934ba641d4bdb98f0d2a44.zip
media-video/vdr: version bump
in this bump is also the gcc11 compile error fixed by patch we skip here vdr-2.4.6 and go straid to vdr-2.4.7 Closes: https://bugs.gentoo.org/786882 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-video/vdr')
-rw-r--r--media-video/vdr/Manifest1
-rw-r--r--media-video/vdr/files/vdr-2.4.7_gcc11.patch292
-rw-r--r--media-video/vdr/vdr-2.4.7.ebuild209
3 files changed, 502 insertions, 0 deletions
diff --git a/media-video/vdr/Manifest b/media-video/vdr/Manifest
index 7611c3c1c5af..a46fe47fab9f 100644
--- a/media-video/vdr/Manifest
+++ b/media-video/vdr/Manifest
@@ -10,4 +10,5 @@ DIST vdr-2.4.1_pinplugin.patch.bz2 8641 BLAKE2B 339bb23ed0f505087bdbbefb192824d5
DIST vdr-2.4.6.tar.bz2 951272 BLAKE2B 52e92eb7e5fdc9bb9209cbef61f8db47e2e9a4750c75bc5b4f88069f95e54faac6b1af5b4c77a6a53990d8f083b6ff8ddeb33418386081c128617217129374fd SHA512 bed8b7740a97b681cf4273c01b6ce80046c1e5914c06d12cffc46fdca615331d0e97771ec09697cf72897583fcf272d83b6bf188ef476715cd0c0c5fd4c5e9d4
DIST vdr-2.4.6_pinplugin.patch.bz2 5176 BLAKE2B 142ad6551b8e37d223acf86f8c2f511cf2cb3664b5ff968bac5e44420c56bf5fdb974360df574141c424cd7a4b1e1489c4a504207420af10f722a77e6d2bad2f SHA512 d5c7263b908302ebf88a5e5ddcb658f56ee92656b40797fd48af1ff9852454adc1d1672cc97411e7744cc31a56f4d0f51df5ece102c21b2aa25d87e3c3c8fe12
DIST vdr-2.4.6_ttxtsubs_v2.patch.bz2 51971 BLAKE2B e4915314e8f659df1c3e0ff631fd0c3dcec89053ff727fd28400dc6eecc49c1d4743a9bedaf3b11fce03fc6082309d4b4658d00a5b01aa5cbe8686e05412f882 SHA512 14c7b4397ba65e0ff9a5fb0705872f1cb6f1cdd1752b14f83f260540da25b5957632900232f83904c3d4fd6759e537c85bda2cce61455729eab3050a96441548
+DIST vdr-2.4.7.tbz2 919632 BLAKE2B be4e1ec365330855e4b2b26f44b1f35dc323e4783e96ef344a67b3e9fe2c0499760ab0f3d27c5e3bdddf5a65ebb65b0c81a62092301d34370aa19d0dd63bb1ab SHA512 41b8453bc6cdbb0db728b5d7d6624ab3ff9034b58ba443a8196f5fcc9fa78d18698cc91905890244e69d482ffc493374e6da2c97baed95fe742b888bdc63e42b
DIST vdr-menuorg-2.3.x.diff 8852 BLAKE2B 19b98d51a69f52ecda5500f51ef1741a8397953b20c490055eab0393da5f56ff9598c3e1e8ed8b915f5877e08deeb9ba7a9ef8d9356ad3a1fa12e3778869174a SHA512 7b41c3a529858a4953a57f21619ea01864e140cc1755ee0b03caf1c4de41e80c3f805653502bc8d39d02a4dfcddf720acd4a8c8bd91f4871eef31d86e8e915c0
diff --git a/media-video/vdr/files/vdr-2.4.7_gcc11.patch b/media-video/vdr/files/vdr-2.4.7_gcc11.patch
new file mode 100644
index 000000000000..866b018b5b79
--- /dev/null
+++ b/media-video/vdr/files/vdr-2.4.7_gcc11.patch
@@ -0,0 +1,292 @@
+https://bugs.gentoo.org/786882
+
+compile fix for gcc-11
+
+Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> (02 May 2021)
+diff -Naur vdr-2.4.7.orig/channels.c vdr-2.4.7/channels.c
+--- vdr-2.4.7.orig/channels.c 2021-05-02 19:34:32.312653108 +0200
++++ vdr-2.4.7/channels.c 2021-05-02 19:39:19.241653108 +0200
+@@ -11,6 +11,7 @@
+ #include <ctype.h>
+ #include "device.h"
+ #include "libsi/si.h"
++using namespace std;
+
+ // IMPORTANT NOTE: in the 'sscanf()' calls there is a blank after the '%d'
+ // format characters in order to allow any number of blanks after a numeric
+diff -Naur vdr-2.4.7.orig/ci.c vdr-2.4.7/ci.c
+--- vdr-2.4.7.orig/ci.c 2021-05-02 19:34:32.313653108 +0200
++++ vdr-2.4.7/ci.c 2021-05-02 19:49:53.216653108 +0200
+@@ -27,6 +27,8 @@
+ #include "skins.h"
+ #include "tools.h"
+
++using namespace std;
++
+ // Set these to 'true' for debug output:
+ static bool DumpTPDUDataTransfer = false;
+ static bool DebugProtocol = false;
+diff -Naur vdr-2.4.7.orig/device.c vdr-2.4.7/device.c
+--- vdr-2.4.7.orig/device.c 2021-05-02 19:34:32.313653108 +0200
++++ vdr-2.4.7/device.c 2021-05-02 19:43:19.071653108 +0200
+@@ -20,6 +20,8 @@
+ #include "status.h"
+ #include "transfer.h"
+
++using namespace std;
++
+ // --- cLiveSubtitle ---------------------------------------------------------
+
+ class cLiveSubtitle : public cReceiver {
+diff -Naur vdr-2.4.7.orig/diseqc.c vdr-2.4.7/diseqc.c
+--- vdr-2.4.7.orig/diseqc.c 2021-05-02 19:34:32.314653108 +0200
++++ vdr-2.4.7/diseqc.c 2021-05-02 19:50:14.177653108 +0200
+@@ -14,6 +14,8 @@
+ #include "sources.h"
+ #include "thread.h"
+
++using namespace std;
++
+ #define ALL_DEVICES (~0) // all bits set to '1'
+ #define MAX_DEVICES 32 // each bit in a 32-bit integer represents one device
+
+diff -Naur vdr-2.4.7.orig/dvbdevice.c vdr-2.4.7/dvbdevice.c
+--- vdr-2.4.7.orig/dvbdevice.c 2021-05-02 19:34:32.314653108 +0200
++++ vdr-2.4.7/dvbdevice.c 2021-05-02 19:50:35.634653108 +0200
+@@ -21,6 +21,8 @@
+ #include "menuitems.h"
+ #include "sourceparams.h"
+
++using namespace std;
++
+ static int DvbApiVersion = 0x0000; // the version of the DVB driver actually in use (will be determined by the first device created)
+
+ #define DVBS_TUNE_TIMEOUT 9000 //ms
+diff -Naur vdr-2.4.7.orig/dvbplayer.c vdr-2.4.7/dvbplayer.c
+--- vdr-2.4.7.orig/dvbplayer.c 2021-05-02 19:34:32.314653108 +0200
++++ vdr-2.4.7/dvbplayer.c 2021-05-02 19:43:47.344653108 +0200
+@@ -15,6 +15,8 @@
+ #include "thread.h"
+ #include "tools.h"
+
++using namespace std;
++
+ // --- cPtsIndex -------------------------------------------------------------
+
+ #define PTSINDEX_ENTRIES 1024
+diff -Naur vdr-2.4.7.orig/dvbspu.c vdr-2.4.7/dvbspu.c
+--- vdr-2.4.7.orig/dvbspu.c 2021-05-02 19:34:32.314653108 +0200
++++ vdr-2.4.7/dvbspu.c 2021-05-02 19:44:08.952653108 +0200
+@@ -17,6 +17,8 @@
+ #include <inttypes.h>
+ #include <math.h>
+
++using namespace std;
++
+ /*
+ * cDvbSpubitmap:
+ *
+diff -Naur vdr-2.4.7.orig/dvbsubtitle.c vdr-2.4.7/dvbsubtitle.c
+--- vdr-2.4.7.orig/dvbsubtitle.c 2021-05-02 19:34:32.315653108 +0200
++++ vdr-2.4.7/dvbsubtitle.c 2021-05-02 19:44:42.537653108 +0200
+@@ -16,6 +16,8 @@
+ #include "device.h"
+ #include "libsi/si.h"
+
++using namespace std;
++
+ #define PAGE_COMPOSITION_SEGMENT 0x10
+ #define REGION_COMPOSITION_SEGMENT 0x11
+ #define CLUT_DEFINITION_SEGMENT 0x12
+diff -Naur vdr-2.4.7.orig/eit.c vdr-2.4.7/eit.c
+--- vdr-2.4.7.orig/eit.c 2021-05-02 19:34:32.315653108 +0200
++++ vdr-2.4.7/eit.c 2021-05-02 19:45:16.962653108 +0200
+@@ -18,6 +18,8 @@
+ #include "libsi/section.h"
+ #include "libsi/descriptor.h"
+
++using namespace std;
++
+ #define VALID_TIME (31536000 * 2) // two years
+
+ #define DBGEIT 0
+diff -Naur vdr-2.4.7.orig/font.c vdr-2.4.7/font.c
+--- vdr-2.4.7.orig/font.c 2021-05-02 19:34:32.315653108 +0200
++++ vdr-2.4.7/font.c 2021-05-02 19:51:53.540653108 +0200
+@@ -21,6 +21,8 @@
+ #include "osd.h"
+ #include "tools.h"
+
++using namespace std;
++
+ const char *DefaultFontOsd = "Sans Serif:Bold";
+ const char *DefaultFontSml = "Sans Serif";
+ const char *DefaultFontFix = "Courier:Bold";
+diff -Naur vdr-2.4.7.orig/menu.c vdr-2.4.7/menu.c
+--- vdr-2.4.7.orig/menu.c 2021-05-02 19:34:32.317653108 +0200
++++ vdr-2.4.7/menu.c 2021-05-02 19:45:44.891653108 +0200
+@@ -33,6 +33,8 @@
+ #include "transfer.h"
+ #include "videodir.h"
+
++using namespace std;
++
+ #define MAXWAIT4EPGINFO 3 // seconds
+ #define MODETIMEOUT 3 // seconds
+ #define NEWTIMERLIMIT 120 // seconds until the start time of a new timer created from the Schedule menu,
+diff -Naur vdr-2.4.7.orig/menuitems.c vdr-2.4.7/menuitems.c
+--- vdr-2.4.7.orig/menuitems.c 2021-05-02 19:34:32.318653108 +0200
++++ vdr-2.4.7/menuitems.c 2021-05-02 19:46:02.483653108 +0200
+@@ -17,6 +17,8 @@
+ #include "skins.h"
+ #include "status.h"
+
++using namespace std;
++
+ #define AUTO_ADVANCE_TIMEOUT 1500 // ms before auto advance when entering characters via numeric keys
+
+ const char *FileNameChars = trNOOP("FileNameChars$ abcdefghijklmnopqrstuvwxyz0123456789-.,#~\\^$[]|()*+?{}/:%@&");
+diff -Naur vdr-2.4.7.orig/mtd.c vdr-2.4.7/mtd.c
+--- vdr-2.4.7.orig/mtd.c 2021-05-02 19:34:32.318653108 +0200
++++ vdr-2.4.7/mtd.c 2021-05-02 19:46:23.355653108 +0200
+@@ -10,6 +10,8 @@
+ #include "mtd.h"
+ #include "receiver.h"
+
++using namespace std;
++
+ //#define DEBUG_MTD
+ #ifdef DEBUG_MTD
+ #define DBGMTD(a...) dsyslog(a)
+diff -Naur vdr-2.4.7.orig/nit.c vdr-2.4.7/nit.c
+--- vdr-2.4.7.orig/nit.c 2021-05-02 19:34:32.318653108 +0200
++++ vdr-2.4.7/nit.c 2021-05-02 19:52:19.012653108 +0200
+@@ -16,6 +16,8 @@
+ #include "libsi/descriptor.h"
+ #include "tools.h"
+
++using namespace std;
++
+ #define DVB_SYSTEM_1 0 // see also dvbdevice.c
+ #define DVB_SYSTEM_2 1
+
+diff -Naur vdr-2.4.7.orig/osd.c vdr-2.4.7/osd.c
+--- vdr-2.4.7.orig/osd.c 2021-05-02 19:34:32.318653108 +0200
++++ vdr-2.4.7/osd.c 2021-05-02 19:47:12.501653108 +0200
+@@ -16,6 +16,8 @@
+ #include "device.h"
+ #include "tools.h"
+
++using namespace std;
++
+ tColor HsvToColor(double H, double S, double V)
+ {
+ if (S > 0) {
+diff -Naur vdr-2.4.7.orig/osdbase.c vdr-2.4.7/osdbase.c
+--- vdr-2.4.7.orig/osdbase.c 2021-05-02 19:34:32.318653108 +0200
++++ vdr-2.4.7/osdbase.c 2021-05-02 19:46:53.516653108 +0200
+@@ -15,6 +15,8 @@
+ #include "remote.h"
+ #include "status.h"
+
++using namespace std;
++
+ // --- cOsdItem --------------------------------------------------------------
+
+ cOsdItem::cOsdItem(eOSState State)
+diff -Naur vdr-2.4.7.orig/recording.c vdr-2.4.7/recording.c
+--- vdr-2.4.7.orig/recording.c 2021-05-02 19:34:32.323653108 +0200
++++ vdr-2.4.7/recording.c 2021-05-02 19:47:45.990653108 +0200
+@@ -31,6 +31,8 @@
+ #include "tools.h"
+ #include "videodir.h"
+
++using namespace std;
++
+ #define SUMMARYFALLBACK
+
+ #define RECEXT ".rec"
+diff -Naur vdr-2.4.7.orig/remux.c vdr-2.4.7/remux.c
+--- vdr-2.4.7.orig/remux.c 2021-05-02 19:34:32.323653108 +0200
++++ vdr-2.4.7/remux.c 2021-05-02 19:48:03.230653108 +0200
+@@ -16,6 +16,8 @@
+ #include "shutdown.h"
+ #include "tools.h"
+
++using namespace std;
++
+ // Set these to 'true' for debug output:
+ static bool DebugPatPmt = false;
+ static bool DebugFrames = false;
+diff -Naur vdr-2.4.7.orig/skinclassic.c vdr-2.4.7/skinclassic.c
+--- vdr-2.4.7.orig/skinclassic.c 2021-05-02 19:34:32.324653108 +0200
++++ vdr-2.4.7/skinclassic.c 2021-05-02 19:48:26.271653108 +0200
+@@ -14,6 +14,8 @@
+ #include "themes.h"
+ #include "videodir.h"
+
++using namespace std;
++
+ #define ScrollWidth (Setup.FontOsdSize / 4)
+ #define TextFrame (Setup.FontOsdSize / 10)
+ #define TextSpacing (Setup.FontOsdSize / 4)
+diff -Naur vdr-2.4.7.orig/skinlcars.c vdr-2.4.7/skinlcars.c
+--- vdr-2.4.7.orig/skinlcars.c 2021-05-02 19:34:32.324653108 +0200
++++ vdr-2.4.7/skinlcars.c 2021-05-02 19:48:46.063653108 +0200
+@@ -63,6 +63,8 @@
+ #include "symbols/teletext.xpm"
+ #include "symbols/volume.xpm"
+
++using namespace std;
++
+ #define Gap (Setup.FontOsdSize / 5 & ~1) // must be even
+ #define TextFrame (Setup.FontOsdSize / TEXT_ALIGN_BORDER)
+ #define TextSpacing (2 * TextFrame)
+diff -Naur vdr-2.4.7.orig/skinsttng.c vdr-2.4.7/skinsttng.c
+--- vdr-2.4.7.orig/skinsttng.c 2021-05-02 19:34:32.324653108 +0200
++++ vdr-2.4.7/skinsttng.c 2021-05-02 19:49:15.256653108 +0200
+@@ -50,6 +50,8 @@
+ #include "symbols/teletext.xpm"
+ #include "symbols/volume.xpm"
+
++using namespace std;
++
+ #define Roundness (Setup.FontOsdSize / 2)
+ #define Gap (Setup.FontOsdSize / 5)
+ #define ScrollWidth (Setup.FontOsdSize / 4)
+diff -Naur vdr-2.4.7.orig/thread.c vdr-2.4.7/thread.c
+--- vdr-2.4.7.orig/thread.c 2021-05-02 19:59:16.883653108 +0200
++++ vdr-2.4.7/thread.c 2021-05-02 20:00:08.879653108 +0200
+@@ -24,6 +24,8 @@
+ #include <unistd.h>
+ #include "tools.h"
+
++using namespace std;
++
+ #define ABORT { dsyslog("ABORT!"); cBackTrace::BackTrace(); abort(); }
+
+ //#define DEBUG_LOCKING // uncomment this line to activate debug output for locking
+diff -Naur vdr-2.4.7.orig/timers.c vdr-2.4.7/timers.c
+--- vdr-2.4.7.orig/timers.c 2021-05-02 19:59:16.883653108 +0200
++++ vdr-2.4.7/timers.c 2021-05-02 19:59:52.287653108 +0200
+@@ -17,6 +17,8 @@
+ #include "status.h"
+ #include "svdrp.h"
+
++using namespace std;
++
+ // IMPORTANT NOTE: in the 'sscanf()' calls there is a blank after the '%d'
+ // format characters in order to allow any number of blanks after a numeric
+ // value!
+diff -Naur vdr-2.4.7.orig/tools.c vdr-2.4.7/tools.c
+--- vdr-2.4.7.orig/tools.c 2021-05-02 20:02:40.535653108 +0200
++++ vdr-2.4.7/tools.c 2021-05-02 20:03:06.859653108 +0200
+@@ -28,6 +28,8 @@
+ #include "i18n.h"
+ #include "thread.h"
+
++using namespace std;
++
+ int SysLogLevel = 3;
+
+ #define MAXSYSLOGBUF 256
diff --git a/media-video/vdr/vdr-2.4.7.ebuild b/media-video/vdr/vdr-2.4.7.ebuild
new file mode 100644
index 000000000000..c1f9413c3022
--- /dev/null
+++ b/media-video/vdr/vdr-2.4.7.ebuild
@@ -0,0 +1,209 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic l10n toolchain-funcs
+
+DESCRIPTION="Video Disk Recorder - turns a pc into a powerful set top box for DVB"
+HOMEPAGE="http://www.tvdr.de/"
+SRC_URI="http://git.tvdr.de/?p=vdr.git;a=snapshot;h=refs/tags/2.4.7;sf=tbz2 -> ${P}.tbz2
+ mainmenuhooks? ( http://vdr.websitec.de/download/${PN}/${PN}-2.4.1/${PN}-2.4.1_mainmenuhook-1.0.1.patch.bz2 )
+ menuorg? ( https://projects.vdr-developer.org/projects/plg-menuorg/repository/revisions/master/raw/vdr-patch/vdr-menuorg-2.3.x.diff )
+ naludump? ( http://www.udo-richter.de/vdr/files/vdr-2.1.5-naludump-0.1.diff )
+ pinplugin? ( http://vdr.websitec.de/download/${PN}/${P}/${PN}-2.4.6_pinplugin.patch.bz2 )
+ ttxtsubs? ( http://vdr.websitec.de/download/${PN}/${P}/${PN}-2.4.6_ttxtsubs_v2.patch.bz2 )
+ permashift? ( http://vdr.websitec.de/download/${PN}/${P}/vdr-2.4-patch-for-permashift.diff.bz2 )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="bidi debug demoplugins html keyboard mainmenuhooks menuorg naludump permashift pinplugin systemd ttxtsubs verbose"
+
+COMMON_DEPEND="
+ virtual/jpeg:*
+ sys-libs/libcap
+ >=media-libs/fontconfig-2.4.2
+ >=media-libs/freetype-2"
+DEPEND="${COMMON_DEPEND}
+ >=virtual/linuxtv-dvb-headers-5.3"
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ media-tv/gentoo-vdr-scripts
+ media-fonts/corefonts
+ bidi? ( dev-libs/fribidi )
+ systemd? ( sys-apps/systemd )"
+BDEPEND="sys-devel/gettext"
+
+REQUIRED_USE="pinplugin? ( !mainmenuhooks )
+ permashift? ( !naludump !pinplugin )"
+
+CONF_DIR="/etc/vdr"
+CAP_FILE="${S}/capabilities.sh"
+CAPS="# Capabilities of the vdr-executable for use by startscript etc."
+
+pkg_setup() {
+ use debug && append-flags -g
+
+ PLUGIN_LIBDIR="/usr/$(get_libdir)/vdr/plugins"
+
+ # use the corrected DIR /var/lib/vdr/* for acct/{user,group) handling
+ if has_version ">=media-tv/gentoo-vdr-scripts-3.0_rc1"; then
+ VIDEO_DIR="/var/lib/vdr/video"
+ else
+ VIDEO_DIR="/var/vdr/video"
+ fi
+
+ tc-export CC CXX AR
+}
+
+add_cap() {
+ local arg
+ for arg; do
+ CAPS="${CAPS}\n${arg}=1"
+ done
+}
+
+lang_po() {
+ LING_PO=$( ls ${S}/po | sed -e "s:.po::g" | cut -d_ -f1 | tr \\\012 ' ' )
+}
+
+src_configure() {
+ # support languages, written from right to left
+ export "BIDI=$(usex bidi 1 0)"
+ # systemd notification support
+ export "SDNOTIFY=$(usex systemd 1 0)"
+ # with/without keyboard
+ export "USE_KBD=$(usex keyboard 1 0)"
+ # detailed compile output for debug
+ export "VERBOSE=$(usex verbose 1 0)"
+}
+
+src_prepare() {
+ # apply maintenance-patches
+ ebegin "Changing paths for gentoo"
+
+ local DVBDIR=/usr/include
+ local i
+ for i in ${DVB_HEADER_PATH} /usr/include/v4l-dvb-hg /usr/include; do
+ [[ -d ${i} ]] || continue
+ if [[ -f ${i}/linux/dvb/dmx.h ]]; then
+ einfo "Found DVB header files in ${i}"
+ DVBDIR=${i}
+ break
+ fi
+ done
+
+ # checking for s2api headers
+ local api_version
+ api_version=$(awk -F' ' '/define DVB_API_VERSION / {print $3}' "${DVBDIR}"/linux/dvb/version.h)
+ api_version=${api_version}*$(awk -F' ' '/define DVB_API_VERSION_MINOR / {print $3}' "${DVBDIR}"/linux/dvb/version.h)
+
+ if [[ ${api_version:-0} -lt 5*3 ]]; then
+ eerror "DVB header files do not contain s2api support or too old for ${P}"
+ eerror "You cannot compile VDR against old dvb-header"
+ die "DVB headers too old"
+ fi
+
+ cat > Make.config <<-EOT || die "cannot write to Make.config"
+ #
+ # Generated by ebuild ${PF}
+ #
+ PREFIX = /usr
+ DVBDIR = ${DVBDIR}
+ PLUGINLIBDIR = ${PLUGIN_LIBDIR}
+ CONFDIR = ${CONF_DIR}
+ ARGSDIR = \$(CONFDIR)/conf.d
+ VIDEODIR = ${VIDEO_DIR}
+ LOCDIR = \$(PREFIX)/share/locale
+ INCDIR = \$(PREFIX)/include
+
+ DEFINES += -DCONFDIR=\"\$(CONFDIR)\"
+ INCLUDES += -I\$(DVBDIR)
+
+ # >=vdr-1.7.36-r1; parameter only used for compiletime on vdr
+ # PLUGINLIBDIR (plugin Makefile old) = LIBDIR (plugin Makefile new)
+ LIBDIR = ${PLUGIN_LIBDIR}
+ PCDIR = /usr/$(get_libdir)/pkgconfig
+
+ EOT
+ eend 0
+
+ eapply "${FILESDIR}/${PN}-2.4.6_gentoo.patch"
+ use demoplugins || eapply "${FILESDIR}/vdr-2.4_remove_plugins.patch"
+ eapply "${FILESDIR}/${PN}-2.4.6_makefile-variables.patch"
+
+ # fix clang/LLVM compile
+ eapply "${FILESDIR}/${PN}-2.4.6_clang.patch"
+
+ # fix gcc-11 compile
+ eapply "${FILESDIR}/${P}_gcc11.patch"
+
+ use naludump && eapply "${DISTDIR}/${PN}-2.1.5-naludump-0.1.diff"
+ use permashift && eapply "${WORKDIR}/${PN}-2.4-patch-for-permashift.diff"
+ use pinplugin && eapply "${WORKDIR}/${PN}-2.4.6_pinplugin.patch"
+ use ttxtsubs && eapply "${WORKDIR}/${PN}-2.4.6_ttxtsubs_v2.patch"
+ use menuorg && eapply "${DISTDIR}/vdr-menuorg-2.3.x.diff"
+ use mainmenuhooks && eapply "${WORKDIR}/${PN}-2.4.1_mainmenuhook-1.0.1.patch"
+
+ add_cap CAP_UTF8 \
+ CAP_IRCTRL_RUNTIME_PARAM \
+ CAP_VFAT_RUNTIME_PARAM \
+ CAP_CHUID \
+ CAP_SHUTDOWN_AUTO_RETRY
+
+ echo -e ${CAPS} > "${CAP_FILE}" || die "cannot write to CAP_FILE"
+
+ # LINGUAS support
+ einfo "\n \t VDR supports the LINGUAS values"
+
+ lang_po
+
+ einfo "\t Please set one of this values in your sytem make.conf"
+ einfo "\t LINGUAS=\"${LING_PO}\"\n"
+
+ if [[ -z ${LINGUAS} ]]; then
+ einfo "\n \t No values in LINGUAS="
+ einfo "\t You will get only english text on OSD \n"
+ fi
+
+ strip-linguas ${LING_PO} en
+
+ default
+}
+
+src_install() {
+ # trick the makefile to not create a VIDEODIR by supplying it with an
+ # existing directory
+ emake VIDEODIR="/" DESTDIR="${ED}" install
+
+ keepdir "${PLUGIN_LIBDIR}"
+
+ # backup for plugins they don't be able to create this dir
+ keepdir "${CONF_DIR}/plugins"
+
+ if use html; then
+ local HTML_DOCS=( *.html )
+ fi
+ local DOCS=( MANUAL INSTALL README* HISTORY CONTRIBUTORS UPDATE-2* )
+ einstalldocs
+
+ insinto /usr/share/vdr
+ doins "${CAP_FILE}"
+
+ fowners vdr:vdr "${CONF_DIR}" -R
+}
+
+pkg_postinst() {
+ elog "Please read the /usr/share/doc/${PF}/UPDATE-2.4"
+ elog "for major changes in this version\n"
+
+ elog "It is a good idea to run vdrplugin-rebuild now.\n"
+
+ elog "To get nice symbols in OSD we recommend to install"
+ elog "\t1. emerge media-fonts/vdrsymbols-ttf"
+ elog "\t2. select font VDRSymbolsSans in Setup\n"
+
+ elog "To get an idea how to proceed now, have a look at our vdr-guide:"
+ elog "\thttps://wiki.gentoo.org/wiki/VDR"
+}