summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-19 22:20:55 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-19 22:20:55 +0100
commit32bc20a9f3090ad26eae322d0b1e50e366f15481 (patch)
tree2b8bb102a009842eb41d6f80a1d9186935334851 /media-video
parentsys-devel/gettext: drop 0.21.1, 0.22.4 (diff)
downloadgentoo-32bc20a9f3090ad26eae322d0b1e50e366f15481.tar.gz
gentoo-32bc20a9f3090ad26eae322d0b1e50e366f15481.tar.bz2
gentoo-32bc20a9f3090ad26eae322d0b1e50e366f15481.zip
media-video/ffmpeg: fix -Wint-conversion in vulkan
Closes: https://bugs.gentoo.org/933130 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild1
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1.2.ebuild1
-rw-r--r--media-video/ffmpeg/files/ffmpeg-6.1.1-wint-inconversion-vulkan.patch35
3 files changed, 37 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild b/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild
index 906e3e77d5e4..5bb0429d2e1f 100644
--- a/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild
@@ -385,6 +385,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.1.1-memory-leak.patch
"${FILESDIR}"/${PN}-6.1.1-wint-inconversion-libgcrypt.patch
"${FILESDIR}"/${PN}-6.1.1-amd-av1-vaapi.patch
+ "${FILESDIR}"/${PN}-6.1.1-wint-inconversion-vulkan.patch
)
MULTILIB_WRAPPED_HEADERS=(
diff --git a/media-video/ffmpeg/ffmpeg-6.1.2.ebuild b/media-video/ffmpeg/ffmpeg-6.1.2.ebuild
index c913e481816f..32eb9022ffd3 100644
--- a/media-video/ffmpeg/ffmpeg-6.1.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1.2.ebuild
@@ -383,6 +383,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.0.1-alignment.patch
"${FILESDIR}"/${PN}-6.1.1-wint-inconversion-libgcrypt.patch
"${FILESDIR}"/${PN}-6.1.1-amd-av1-vaapi.patch
+ "${FILESDIR}"/${PN}-6.1.1-wint-inconversion-vulkan.patch
)
MULTILIB_WRAPPED_HEADERS=(
diff --git a/media-video/ffmpeg/files/ffmpeg-6.1.1-wint-inconversion-vulkan.patch b/media-video/ffmpeg/files/ffmpeg-6.1.1-wint-inconversion-vulkan.patch
new file mode 100644
index 000000000000..56c2d11efcd1
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-6.1.1-wint-inconversion-vulkan.patch
@@ -0,0 +1,35 @@
+From 5860a966d2fffbbda1af0014f0a4d37a21c4f2ca Mon Sep 17 00:00:00 2001
+From: Lynne <dev@lynne.ee>
+Date: Wed, 31 Jan 2024 14:15:04 +0100
+Subject: [PATCH] lavfi/vsrc_testsrc_vulkan: fix -Wint-conversion
+
+While VK_NULL_HANDLE is equivalent to NULL on 64-bit platforms, the same is not
+true across all platforms.
+
+Fixes building with gcc-14.
+---
+ libavfilter/vsrc_testsrc_vulkan.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libavfilter/vsrc_testsrc_vulkan.c b/libavfilter/vsrc_testsrc_vulkan.c
+index 8761c21dfd1ed..1720bfac5e3a2 100644
+--- a/libavfilter/vsrc_testsrc_vulkan.c
++++ b/libavfilter/vsrc_testsrc_vulkan.c
+@@ -231,7 +231,7 @@ static int testsrc_vulkan_activate(AVFilterContext *ctx)
+ return AVERROR(ENOMEM);
+
+ err = ff_vk_filter_process_simple(&s->vkctx, &s->e, &s->pl, s->picref, NULL,
+- NULL, &s->opts, sizeof(s->opts));
++ VK_NULL_HANDLE, &s->opts, sizeof(s->opts));
+ if (err < 0)
+ return err;
+ }
+@@ -250,7 +250,7 @@ static int testsrc_vulkan_activate(AVFilterContext *ctx)
+ frame->sample_aspect_ratio = s->sar;
+ if (!s->draw_once) {
+ err = ff_vk_filter_process_simple(&s->vkctx, &s->e, &s->pl, frame, NULL,
+- NULL, &s->opts, sizeof(s->opts));
++ VK_NULL_HANDLE, &s->opts, sizeof(s->opts));
+ if (err < 0) {
+ av_frame_free(&frame);
+ return err;