summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-28 07:55:02 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-28 09:53:38 -0500
commit96fb6735bb117aedd5fb3e9e5f80a9d4fbfd6fea (patch)
tree4cf47c30b1f199896d91d7dfad9844dd57759766 /media-video
parentapp-text/iso-codes: Version bump to 4.13.0 (diff)
downloadgentoo-96fb6735bb117aedd5fb3e9e5f80a9d4fbfd6fea.tar.gz
gentoo-96fb6735bb117aedd5fb3e9e5f80a9d4fbfd6fea.tar.bz2
gentoo-96fb6735bb117aedd5fb3e9e5f80a9d4fbfd6fea.zip
media-video/mpv: don't unnecessarily pass -I/-L for raspberry-pi
If meson.build doesn't find the pkg-config file, it'll fail. So there's no sense in adding this ourselves. mpv already looks for the .pc file in /opt/vc for userland-bin, and meson considers SYSROOT even with absolute paths (cross works). Prefix is untested (would need more setting up to try this on arm), may or may not need to use PKG_CONFIG_PATH so it can find brcmegl.pc depending on how meson handles it -- but either way is unlikely to work given userland-bin's .pc are not modified to include EPREFIX (not going to worry unless someone actually uses this configuration). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-0.35.1.ebuild5
-rw-r--r--media-video/mpv/mpv-9999.ebuild5
2 files changed, 0 insertions, 10 deletions
diff --git a/media-video/mpv/mpv-0.35.1.ebuild b/media-video/mpv/mpv-0.35.1.ebuild
index bcd28382376d..5ea6dc240af6 100644
--- a/media-video/mpv/mpv-0.35.1.ebuild
+++ b/media-video/mpv/mpv-0.35.1.ebuild
@@ -147,11 +147,6 @@ src_configure() {
fi
fi
- if use raspberry-pi; then
- append-cflags -I"${ESYSROOT}"/opt/vc/include
- append-ldflags -L"${ESYSROOT}"/opt/vc/lib
- fi
-
mpv_feature_multi() {
local use set
for use in ${1} ${2}; do
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 11323310aeb0..34293c859ac9 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -147,11 +147,6 @@ src_configure() {
fi
fi
- if use raspberry-pi; then
- append-cflags -I"${ESYSROOT}"/opt/vc/include
- append-ldflags -L"${ESYSROOT}"/opt/vc/lib
- fi
-
mpv_feature_multi() {
local use set
for use in ${1} ${2}; do