summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-03-22 09:03:51 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-03-22 09:04:03 -0400
commitff68e8df77aa55d645f40e3011e4f276e8df87dd (patch)
treefae964a01183a993413c81cd0d801eaa3b57c574 /net-analyzer/2ping/2ping-4.5.1.ebuild
parentdev-php/PEAR-Exception: Mark as stabilize-allarches (diff)
downloadgentoo-ff68e8df77aa55d645f40e3011e4f276e8df87dd.tar.gz
gentoo-ff68e8df77aa55d645f40e3011e4f276e8df87dd.tar.bz2
gentoo-ff68e8df77aa55d645f40e3011e4f276e8df87dd.zip
net-analyzer/2ping: version bump to 4.5.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-analyzer/2ping/2ping-4.5.1.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-4.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-4.5.1.ebuild b/net-analyzer/2ping/2ping-4.5.1.ebuild
new file mode 100644
index 000000000000..cf86e0c1d814
--- /dev/null
+++ b/net-analyzer/2ping/2ping-4.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="https://www.finnie.org/software/2ping/"
+SRC_URI="https://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="server"
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/2ping.1
+ dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}