summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-08 10:44:35 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-08 10:44:49 +0100
commit1003503f832060ce6d344c9b80745cf23241a441 (patch)
treeccb94d0b20787293967a89cff3632fad0ae0bea9 /net-analyzer/pathload/pathload-1.3.2-r1.ebuild
parentnet-analyzer/pathload: Use HTTPS (diff)
downloadgentoo-1003503f832060ce6d344c9b80745cf23241a441.tar.gz
gentoo-1003503f832060ce6d344c9b80745cf23241a441.tar.bz2
gentoo-1003503f832060ce6d344c9b80745cf23241a441.zip
net-analyzer/pathload: EAPI=7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/pathload/pathload-1.3.2-r1.ebuild')
-rw-r--r--net-analyzer/pathload/pathload-1.3.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/pathload/pathload-1.3.2-r1.ebuild b/net-analyzer/pathload/pathload-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..27b8252d8e52
--- /dev/null
+++ b/net-analyzer/pathload/pathload-1.3.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Non-intrusive utility for estimation of available bandwidth of Internet paths"
+HOMEPAGE="https://www.cc.gatech.edu/fac/constantinos.dovrolis/bw-est/pathload.html"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}_${PV}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-make.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ${PN}_snd ${PN}_rcv
+ dodoc CHANGELOG CHANGES README
+}