summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2020-03-10 22:51:12 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-25 15:45:26 +0200
commit5485730b192d49b06a529744e29315f06277287c (patch)
tree9dacf21884d8562f4d3a2a014820baa866d786d4 /net-analyzer/python-gvm/python-gvm-1.2.0.ebuild
parentnet-analyzer/gvm-tools: overtake maintainership (diff)
downloadgentoo-5485730b192d49b06a529744e29315f06277287c.tar.gz
gentoo-5485730b192d49b06a529744e29315f06277287c.tar.bz2
gentoo-5485730b192d49b06a529744e29315f06277287c.zip
net-analyzer/python-gvm: Version Bump to 1.2.0
Bug: https://bugs.gentoo.org/712094 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-1.2.0.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-1.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-1.2.0.ebuild b/net-analyzer/python-gvm/python-gvm-1.2.0.ebuild
new file mode 100644
index 000000000000..8643fbe95e03
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # Exlude tests & docs to fix build issue
+ sed \
+ -e "s/packages=find_packages(exclude=.*/packages=find_packages(exclude=['tests*', 'docs']),/g" \
+ -i "$S"/setup.py || die
+}