summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-16 12:25:30 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-16 12:25:30 +0100
commit47167bd6764afc1ca3a2110bb131ab43a36f6cae (patch)
treea941965fad49f5f9e52c7408e2bd4fe8cffac098 /net-analyzer/sarg
parentnet-analyzer/etherape: Version 0.9.16. (diff)
downloadgentoo-47167bd6764afc1ca3a2110bb131ab43a36f6cae.tar.gz
gentoo-47167bd6764afc1ca3a2110bb131ab43a36f6cae.tar.bz2
gentoo-47167bd6764afc1ca3a2110bb131ab43a36f6cae.zip
net-analyzer/sarg: Version 2.3.11.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/sarg')
-rw-r--r--net-analyzer/sarg/Manifest1
-rw-r--r--net-analyzer/sarg/files/sarg-2.3.11-configure.patch31
-rw-r--r--net-analyzer/sarg/sarg-2.3.11.ebuild42
3 files changed, 74 insertions, 0 deletions
diff --git a/net-analyzer/sarg/Manifest b/net-analyzer/sarg/Manifest
index 402130e28498..37b5e2df53ed 100644
--- a/net-analyzer/sarg/Manifest
+++ b/net-analyzer/sarg/Manifest
@@ -1 +1,2 @@
DIST sarg-2.3.10.tar.gz 1278071 BLAKE2B a9412069826328a7828cc3759858160a8e9121fee30697b8c54bc2e6ca948255f297147ff8692e3a62fe6c0a2b596a1a73e1090d03ef1fdacdd692866e6ef27d SHA512 d0a61ac6d455feb8fff024c21f1b7547471ef8cf847fd54d9042881cac3ee14a41fe2a8ea9e0fc2bd2ea0448714ba457e9070282c31e4f3c879e4d83d00ecb2d
+DIST sarg-2.3.11.tar.gz 1346884 BLAKE2B f1ba5e5d3531b611cca1e18444b24772d5f6fb31622d3702ce34bf7e5208b7ff04000ed80c984ff103f785dd9b7015f56403b8389100bbd02cdbf936c8343be9 SHA512 a5bf5c0f696a9d58d9dd1d631d2b458e7a48f597e7a084b032b2feb6185440b08babe7ffaaefc04676f0dbc11301084d1896b6246a7e79a10acdbd7aa7882ff6
diff --git a/net-analyzer/sarg/files/sarg-2.3.11-configure.patch b/net-analyzer/sarg/files/sarg-2.3.11-configure.patch
new file mode 100644
index 000000000000..583bfeb0e8e1
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-2.3.11-configure.patch
@@ -0,0 +1,31 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,6 +2,7 @@
+ AC_INIT([sarg],[2.3.9])
+ AC_CONFIG_SRCDIR([log.c])
+ AC_CONFIG_AUX_DIR(cfgaux)
++AC_CONFIG_MACRO_DIR(m4)
+
+ AC_CANONICAL_HOST
+
+@@ -26,6 +27,11 @@
+ dnl C99 support is required to define LLONG_MAX (at least on CentOS 5.7)
+ AC_PROG_CC_C99
+
++dnl mkdir_p / MKDIR_P
++AC_PROG_MKDIR_P
++mkdir_p="$MKDIR_P"
++AC_SUBST(mkdir_p)
++
+ # Report more warnings to improve code quality.
+ CFLAGS="${CFLAGS} -Wall -Wno-sign-compare"
+
+@@ -60,7 +66,7 @@
+
+ case "$host" in
+ *-solaris*)
+- LDFLAGS="${LDFLAGS} -lsocket -lnsl"
++ LIBS="${LIBS} -lsocket -lnsl"
+ CFLAGS="-DSOLARIS ${CFLAGS}"
+ ;;
+ esac
diff --git a/net-analyzer/sarg/sarg-2.3.11.ebuild b/net-analyzer/sarg/sarg-2.3.11.ebuild
new file mode 100644
index 000000000000..33a65ab49a99
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.3.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="http://sarg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+gd ldap pcre"
+
+DEPEND="
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.10-config.patch
+ "${FILESDIR}"/${PN}-2.3.11-configure.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gd) \
+ $(use_with ldap) \
+ $(use_with pcre) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}