summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/sslscan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/sslscan')
-rw-r--r--net-analyzer/sslscan/Manifest1
-rw-r--r--net-analyzer/sslscan/files/sslscan-1.8.2-makefile.patch11
-rw-r--r--net-analyzer/sslscan/metadata.xml10
-rw-r--r--net-analyzer/sslscan/sslscan-1.8.2.ebuild35
4 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/sslscan/Manifest b/net-analyzer/sslscan/Manifest
new file mode 100644
index 000000000000..ad4967773a42
--- /dev/null
+++ b/net-analyzer/sslscan/Manifest
@@ -0,0 +1 @@
+DIST sslscan-1.8.2.tgz 22176 SHA256 3b728804456042d96d5c8ccd42326f8e5719d091986793bb7b852a36b50d2b3e SHA512 89dfa5426cf9c5631fcf379931eabf020d4b084feb88bbd61e81a4b927ad19275b8613adb06a39eb4d9ce2992f4460383935f5903cfa8f0f1a2e72f8a86ec8a3 WHIRLPOOL 127bfa9e9d95475846569d5dc44f4891a34e0b697dcbf733f61d5c58ed36f54e89e5898acece832c8269b05b5869f751753f58aaf3f7bd8f4fd3e95e93211183
diff --git a/net-analyzer/sslscan/files/sslscan-1.8.2-makefile.patch b/net-analyzer/sslscan/files/sslscan-1.8.2-makefile.patch
new file mode 100644
index 000000000000..c4ceb6ae7e64
--- /dev/null
+++ b/net-analyzer/sslscan/files/sslscan-1.8.2-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.~1~ 2009-09-01 14:35:59.000000000 +0200
++++ Makefile 2012-08-06 08:00:40.550143945 +0200
+@@ -3,7 +3,7 @@
+ MANPATH = /usr/share/man/
+
+ all:
+- gcc -g -Wall -lssl -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
++ $(CC) -Wall $(LDFLAGS) $(CFLAGS) -o sslscan $(SRCS) -lssl -lcrypto
+
+ install:
+ cp sslscan $(BINPATH)
diff --git a/net-analyzer/sslscan/metadata.xml b/net-analyzer/sslscan/metadata.xml
new file mode 100644
index 000000000000..141f7b271a9c
--- /dev/null
+++ b/net-analyzer/sslscan/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sslscan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/sslscan/sslscan-1.8.2.ebuild b/net-analyzer/sslscan/sslscan-1.8.2.ebuild
new file mode 100644
index 000000000000..097792fef128
--- /dev/null
+++ b/net-analyzer/sslscan/sslscan-1.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Fast SSL port scanner"
+HOMEPAGE="http://sourceforge.net/projects/sslscan/"
+SRC_URI="mirror://sourceforge/sslscan/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# Depend on -bindist since sslscan unconditionally requires elliptic
+# curve support, bug 491102
+DEPEND="dev-libs/openssl:0[-bindist]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin sslscan
+ doman sslscan.1
+ dodoc Changelog
+}