summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-28 11:51:13 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-30 21:33:38 +0300
commit848e926dbe0e16264a92db986b89cdd5df55fc4e (patch)
treec90ecf8462e8d6dd54ce50c0c8b70d8e4756ca7f /net-analyzer/tcpreplay
parentnet-analyzer/tcpreplay: add 4.5.1 (diff)
downloadgentoo-848e926dbe0e16264a92db986b89cdd5df55fc4e.tar.gz
gentoo-848e926dbe0e16264a92db986b89cdd5df55fc4e.tar.bz2
gentoo-848e926dbe0e16264a92db986b89cdd5df55fc4e.zip
net-analyzer/tcpreplay: update live ebuild
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37692 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-9999.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/net-analyzer/tcpreplay/tcpreplay-9999.ebuild b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
index 28758be51d1b..12b855475582 100644
--- a/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,6 +35,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ pathfind # sun/solaris only command, bug 900040
+)
+
DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
PATCHES=(
@@ -59,16 +63,19 @@ src_prepare() {
src_configure() {
use elibc_musl && append-flags "-lfts"
# By default it uses static linking. Avoid that, bug #252940
- econf \
- $(use_enable debug) \
- $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
- $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
- --enable-dynamic-link \
- --enable-local-libopts \
- --enable-shared \
- --with-libdnet \
- --with-testnic2=lo \
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config)
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump)
+ --enable-dynamic-link
+ --enable-local-libopts
+ --enable-shared
+ --with-libdnet
+ --with-testnic2=lo
--with-testnic=lo
+ )
+
+ econf "${myeconfargs[@]}"
}
src_test() {