summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 06:57:30 +0100
committerSam James <sam@gentoo.org>2022-08-27 07:05:56 +0100
commitf8a5c2cc9833bc9c4f85eb8be95bc5dcc83ea8e8 (patch)
treee87b0647060ab357e07a3ae5f260dc25875e0254 /net-analyzer/tcpreplay
parentnet-libs/libpcap: drop -L/usr/lib from pcap-config output (diff)
downloadgentoo-f8a5c2cc9833bc9c4f85eb8be95bc5dcc83ea8e8.tar.gz
gentoo-f8a5c2cc9833bc9c4f85eb8be95bc5dcc83ea8e8.tar.bz2
gentoo-f8a5c2cc9833bc9c4f85eb8be95bc5dcc83ea8e8.zip
net-analyzer/tcpreplay: add 4.4.2
Bug: https://bugs.gentoo.org/836240 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild86
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-9999.ebuild1
3 files changed, 87 insertions, 1 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index ad3c5de2681d..89a8c894147b 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,2 +1,3 @@
DIST tcpreplay-4.3.4.tar.xz 739280 BLAKE2B 8b680363ee182fc7581f99cc4587d50e36285446d07a5be370e2439b31582ad88c786c11d662e28dadc5b69aee376889b1c0f6a86d61c106426ab6ab2c085012 SHA512 6d19cf492114c68a9fafcf7790c08f31607d2c0112e02fa41eed8747255bbbef85f281f74348e1d51f1d476b88f07d64715224618ec15268688baefaf7cc7124
DIST tcpreplay-4.4.1.tar.xz 751036 BLAKE2B cf6a4e23f68fd0d6f23392c3ded14ea6486d275eeb8e278ce02d6b34e8b426e69841858cac49cc5ea952e0398f2960049789d16180b0896e38d665511237b352 SHA512 25a4a94b7c0c416b8ef57aba5640803dcd6e271fe8789f3f6e281529e336e326b35738d7673fd44ac4ded0faf577dc4c6255b926bd67b8ba5104a8bad81a98f1
+DIST tcpreplay-4.4.2.tar.xz 750592 BLAKE2B c1f0bad69eca7e086aeb7100c4a35e2984a81412f81eaf981d969d24510736788e4657b511308b38ffbf88021c23272c51b9265eb2fb08318352d3eb8bed0a2a SHA512 78e5482c0cd70a55aa80167c602b33811fa01203860fab4b2d504da71a95e218356ea0cc85254e12be7cb13b611487a150f13df94f9da274661f71e921bd6045
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild
new file mode 100644
index 000000000000..28758be51d1b
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+S="${WORKDIR}"/${P/_/-}
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+IUSE="debug pcapnav +tcpdump"
+
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
+ >=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ elibc_musl? ( sys-libs/fts-standalone )
+ pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use elibc_musl && append-flags "-lfts"
+ # By default it uses static linking. Avoid that, bug #252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]] ; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up."
+ die "self test failed - see ${S}/test/test.log"
+ }
+ fi
+}
diff --git a/net-analyzer/tcpreplay/tcpreplay-9999.ebuild b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
index 01eca400dbe0..28758be51d1b 100644
--- a/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
@@ -39,7 +39,6 @@ DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
- "${FILESDIR}"/${PN}-4.4.1-fix-bashism-configure.patch
)
src_prepare() {