summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-07-23 22:39:34 +0200
committerSam James <sam@gentoo.org>2023-08-07 06:03:35 +0100
commit3115deb6fc7ea40025df2387fa9891109f2cba9b (patch)
tree13ce991057ea4bf0f49a87ad66fed98f3f7a8ff6 /net-analyzer/wtfis
parentnet-analyzer/wtfis: drop 0.5.1 (diff)
downloadgentoo-3115deb6fc7ea40025df2387fa9891109f2cba9b.tar.gz
gentoo-3115deb6fc7ea40025df2387fa9891109f2cba9b.tar.bz2
gentoo-3115deb6fc7ea40025df2387fa9891109f2cba9b.zip
net-analyzer/wtfis: add 0.6.2
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/32017 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/wtfis')
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/wtfis-0.6.2.ebuild38
-rw-r--r--net-analyzer/wtfis/wtfis-9999.ebuild5
3 files changed, 41 insertions, 3 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
index 5073d6a6320b..a6ddaf430b64 100644
--- a/net-analyzer/wtfis/Manifest
+++ b/net-analyzer/wtfis/Manifest
@@ -1 +1,2 @@
DIST wtfis-0.6.1.gh.tar.gz 472803 BLAKE2B 9764d54d88bc8709b67673200a295bc0520438733b45c98d779e088bbcf57778007caf7fa0dcafed881d94bb6b7216f8f00b30b0b0bd528252c18e449865c382 SHA512 75f44416979f7196879a5a3f528caed7154c29f6a79b9ba116bba98f609b5d4bf9f2f78c2eba1e1629fa9f50c60b5678adac98150843fc1ffbedff8bcae3f0f3
+DIST wtfis-0.6.2.gh.tar.gz 473959 BLAKE2B 776b8cafa5acca6648c168198b47ae9f47b8d72b8454880adcb6e63280f9bf60c83184e5ce3054058232eecbf80ead880d4d454ce3b7ca664d4a0bf1d4451e59 SHA512 11ca3987d4ee8e66ad662136b7d4262c26556359c253382fefae3b70aa1c09b95c326a5347299c519eaf54724099402917977ad322eb07dbec765a9d21f39549
diff --git a/net-analyzer/wtfis/wtfis-0.6.2.ebuild b/net-analyzer/wtfis/wtfis-0.6.2.ebuild
new file mode 100644
index 000000000000..90a04b2348d5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-2.0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/net-analyzer/wtfis/wtfis-9999.ebuild b/net-analyzer/wtfis/wtfis-9999.ebuild
index 4f7452d042b6..aca9bc27250e 100644
--- a/net-analyzer/wtfis/wtfis-9999.ebuild
+++ b/net-analyzer/wtfis/wtfis-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
@@ -22,8 +22,7 @@ LICENSE="MIT"
SLOT="0"
RDEPEND="
- <dev-python/pydantic-2[${PYTHON_USEDEP}]
- >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.0.3[${PYTHON_USEDEP}]
>=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
>=dev-python/rich-12.6.0[${PYTHON_USEDEP}]