summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-09-07 23:41:56 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-14 11:57:13 +0200
commit4c1126afa7fecfa93c933f4bb62879d2d6c70acb (patch)
tree0daec14b2c73185bb304fe986e3d5740d64609d2 /net-analyzer
parentnet-analyzer/notus-scanner: Adds a check on log's dir owner and the logfile t... (diff)
downloadgentoo-4c1126afa7fecfa93c933f4bb62879d2d6c70acb.tar.gz
gentoo-4c1126afa7fecfa93c933f4bb62879d2d6c70acb.tar.bz2
gentoo-4c1126afa7fecfa93c933f4bb62879d2d6c70acb.zip
net-analyzer/notus-scanner: add 22.6.4
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38512 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/notus-scanner/Manifest1
-rw-r--r--net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-analyzer/notus-scanner/Manifest b/net-analyzer/notus-scanner/Manifest
index 494907c14216..51eda960450e 100644
--- a/net-analyzer/notus-scanner/Manifest
+++ b/net-analyzer/notus-scanner/Manifest
@@ -1,2 +1,3 @@
DIST notus-scanner-22.6.2.tar.gz 316406 BLAKE2B c24ec5e4fd9f8fc181145d64580d04f7045ccf1a7570f855f0a8a79bcea842fe7a73d91fadecd61c10b94cb3ee68ecae98b0f91b4059b84258765be98c95057f SHA512 ecbbb79950908641c2b83d379d141b189b8e0e27cac17753cbb381a5f4ebf28d7100f60bd24fc284c2681abc889f6fee36a64f469ac0b37323940eaeae7e7522
DIST notus-scanner-22.6.3.tar.gz 293997 BLAKE2B 889416d2324088dc11f2df5146b3c88b276d1170552f55b2cb7ef49f4d8d855b98d6c0e53a1d49bd725b97b88c12df69a1997a38a614aa941dd699d0efb1de51 SHA512 fc3a05a3a9d61dd0b7a9913cfbbf507fec9dd3797a42a82283d14ab7fa8090fbc847487cf3a1d064f49572dda9acadba4bd7d30003fd32a179f572e327254546
+DIST notus-scanner-22.6.4.tar.gz 293607 BLAKE2B 75bdbd9d6247a2b9afaf7b049b8b80b2a44714ad4d6c951c9d14898c8bce319c39c4a19162fe1a380ef638164f025c210346ee5659ed1caefdb91bef2a0906d7 SHA512 5a3f23425a1945636c6fd9dd7b3ad39cf6f02920c33aaa35e3aa7ae1dfb8962d60f8e8519047e631c0e72a1a75c56ac5350c9dd291c20947fac2d4cdbb7f6387
diff --git a/net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild b/net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild
new file mode 100644
index 000000000000..43056ee11d51
--- /dev/null
+++ b/net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 readme.gentoo-r1 systemd
+
+DESCRIPTION="Notus is a vulnerability scanner for creating results from local security checks"
+HOMEPAGE="https://github.com/greenbone/notus-scanner"
+SRC_URI="https://github.com/greenbone/notus-scanner/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3 AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-user/gvm
+ net-libs/paho-mqtt-c
+ >=dev-python/psutil-6.0[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.5.1[${PYTHON_USEDEP}]
+ <dev-python/packaging-24.2[${PYTHON_USEDEP}]
+ >=dev-python/paho-mqtt-1.5.1[${PYTHON_USEDEP}]
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-misc/mosquitto
+"
+
+PATCHES=(
+ "${FILESDIR}"/notus-scanner-22.6.2-remove-tests.patch
+)
+
+DOC_CONTENTS="
+For validating the feed content, a GnuPG keychain with the Greenbone Community Feed integrity key needs to be created.
+Please, read here on how to create it:
+https://greenbone.github.io/docs/latest/22.4/source-build/index.html#feed-validation
+https://wiki.gentoo.org/wiki/Greenbone_Vulnerability_Management#Notus_Scanner
+
+To enable feed validation, edit /etc/gvm/${PN}.toml
+and set
+disable-hashsum-verification = false"
+DISABLE_AUTOFORMATTING=true
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ insinto /etc/gvm
+ use prefix || fowners -R gvm:gvm /etc/gvm
+ newins "${FILESDIR}/${PN}.toml" "${PN}.toml"
+ use prefix || fowners gvm:gvm "/etc/gvm/${PN}.toml"
+
+ # Set proper permissions on required files/directories
+ keepdir /var/lib/notus
+ keepdir /var/lib/notus/products
+ keepdir /var/lib/notus/advisories
+ if ! use prefix; then
+ fowners -R gvm:gvm /var/lib/notus
+ fi
+
+ # Adding notus-scanner.log to logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" "${PN}"
+
+ # Set proper permissions on required files/directories
+ keepdir /var/log/gvm
+ if ! use prefix; then
+ fowners -R gvm:gvm /var/log/gvm
+ fi
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ systemd_dounit config/${PN}.service
+
+ systemd_install_serviced "${FILESDIR}/notus-scanner.service.conf" \
+ ${PN}.service
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}