summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 14:28:52 +0100
committerSam James <sam@gentoo.org>2023-05-01 14:28:52 +0100
commitf1654f0340d745825110a57eeddfdfa0afd7e33a (patch)
tree4ddbb77aa915200ad520554bdd01adce8cc17760 /net-analyzer
parentnet-analyzer/tcpdump: drop 4.99.1-r1, 4.99.2 (diff)
downloadgentoo-f1654f0340d745825110a57eeddfdfa0afd7e33a.tar.gz
gentoo-f1654f0340d745825110a57eeddfdfa0afd7e33a.tar.bz2
gentoo-f1654f0340d745825110a57eeddfdfa0afd7e33a.zip
net-analyzer/tcpreplay: drop 4.4.2-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch60
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild87
3 files changed, 0 insertions, 148 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index 8e0d9474b8ee..1aaec4716666 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,2 +1 @@
-DIST tcpreplay-4.4.2.tar.xz 750592 BLAKE2B c1f0bad69eca7e086aeb7100c4a35e2984a81412f81eaf981d969d24510736788e4657b511308b38ffbf88021c23272c51b9265eb2fb08318352d3eb8bed0a2a SHA512 78e5482c0cd70a55aa80167c602b33811fa01203860fab4b2d504da71a95e218356ea0cc85254e12be7cb13b611487a150f13df94f9da274661f71e921bd6045
DIST tcpreplay-4.4.3.tar.xz 750072 BLAKE2B 218fe1c5faab0fdd75a031afce8f468c85886a4cf21a4d9bd34089bd106756ee0e65e0df605efecb3260ccff266553a44d8ee10249b35524a044c6c5db86fcc7 SHA512 d8186a5faf3fbe5505da34cfc466c0375c4f298c997fe85505ea898c8c1241c16f98269596b682983a3e5cbd8493882334c925ff750d95995f3b13c5b83357cf
diff --git a/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch b/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
deleted file mode 100644
index 81a5a0086958..000000000000
--- a/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-https://github.com/appneta/tcpreplay/pull/757
-
-From 096197e584ebb7d646eef75e5a8654f7192a0af2 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Thu, 24 Nov 2022 07:30:28 +0100
-Subject: [PATCH] configure.ac: Avoid implicit int, implicit function
- declarations
-
-Do not call exit without declaring it. Add #include <unistd.h>
-for fork. Add missing int type to the definition of main.
-
-Implicit ints and implicit function declarations were removed from
-C in 1999 and will not be supported by future compilers.
---- a/configure.ac
-+++ b/configure.ac
-@@ -1681,8 +1681,8 @@ int
- main (int argc, char *argv[])
- {
- if (strncmp(PCAPNAV_VERSION, PCAPNAV_TEST, 3) >= 0)
-- exit(0);
-- exit(1);
-+ return 0;
-+ return 1;
- } ]])],[libpcapnav_ver=yes
- AC_MSG_RESULT(>= 0.4)],[libpcapnav_ver=no
- AC_MSG_RESULT(< 0.4)],[libpcapnav_ver=no
-@@ -1726,26 +1726,27 @@ case "$host_os" in
- #include <sys/types.h>
- #include <sys/wait.h>
- #include <stdio.h>
-+ #include <unistd.h>
- unsigned char a[[5]] = { 1, 2, 3, 4, 5 };
-- main() {
-+ int main() {
- unsigned int i;
- pid_t pid;
- int status;
- /* avoid "core dumped" message */
- pid = fork();
- if (pid < 0)
-- exit(2);
-+ return 2;
- if (pid > 0) {
- /* parent */
- pid = waitpid(pid, &status, 0);
- if (pid < 0)
-- exit(3);
-- exit(!WIFEXITED(status));
-+ return 3;
-+ return !WIFEXITED(status);
- }
- /* child */
- i = *(unsigned int *)&a[[1]];
- printf("%d\n", i);
-- exit(0);
-+ return 0;
- }
- EOF
- ${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS \
-
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild
deleted file mode 100644
index 2cc1e8f862c3..000000000000
--- a/net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
-HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
- inherit git-r3
-else
- SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm ~sparc x86"
-fi
-
-S="${WORKDIR}"/${P/_/-}
-
-LICENSE="BSD GPL-3"
-SLOT="0"
-IUSE="debug pcapnav +tcpdump"
-
-# libpcapnav for pcapnav-config
-BDEPEND="
- net-libs/libpcapnav
- >=sys-devel/autogen-5.18.4[libopts]
-"
-DEPEND="
- dev-libs/libdnet
- >=net-libs/libpcap-0.9
- elibc_musl? ( sys-libs/fts-standalone )
- pcapnav? ( net-libs/libpcapnav )
- tcpdump? ( net-analyzer/tcpdump )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
- "${FILESDIR}"/${PN}-4.4.2-configure-clang16.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
- src/common/sendpacket.c || die
- sed -i \
- -e 's|@\([A-Z_]*\)@|$(\1)|g' \
- -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
- -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
- src/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- use elibc_musl && append-flags "-lfts"
- # By default it uses static linking. Avoid that, bug #252940
- econf \
- $(use_enable debug) \
- $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
- $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
- --enable-dynamic-link \
- --enable-local-libopts \
- --enable-shared \
- --with-libdnet \
- --with-testnic2=lo \
- --with-testnic=lo
-}
-
-src_test() {
- if [[ ! ${EUID} -eq 0 ]] ; then
- ewarn "Some tests were disabled due to FEATURES=userpriv"
- ewarn "To run all tests issue the following command as root:"
- ewarn " # make -C ${S}/test"
- emake -j1 -C test tcpprep
- else
- emake -j1 test || {
- ewarn "Note that some tests require eth0 iface to be up."
- die "self test failed - see ${S}/test/test.log"
- }
- fi
-}