summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/pdns-ldap-backend
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/pdns-ldap-backend')
-rw-r--r--net-dns/pdns-ldap-backend/Manifest1
-rw-r--r--net-dns/pdns-ldap-backend/metadata.xml9
-rw-r--r--net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild40
3 files changed, 50 insertions, 0 deletions
diff --git a/net-dns/pdns-ldap-backend/Manifest b/net-dns/pdns-ldap-backend/Manifest
new file mode 100644
index 000000000000..b32ebe54729a
--- /dev/null
+++ b/net-dns/pdns-ldap-backend/Manifest
@@ -0,0 +1 @@
+DIST pdns-ldap-backend-0.2.tar.gz 745650 SHA256 6bad9b104129eeffebe2679dbc39c01183cc062b1b02c8eb5ba7903625240473 SHA512 1a9eb0282abd9dea945150412a77d9cad4ee5fb114b621396928adb6db5994a0ee54b084281b723460e2943c15570c783da518a51314636302d9179832a26990 WHIRLPOOL bb66feec72a7ad999b366ddd40c3b112b60173dfc937d4808e74a804b03bd6b85186dad0fa8ad0d8e21c47fe5c870e100dd3d9717d30b5054ba0046fb50b1736
diff --git a/net-dns/pdns-ldap-backend/metadata.xml b/net-dns/pdns-ldap-backend/metadata.xml
new file mode 100644
index 000000000000..d3839a9b58dc
--- /dev/null
+++ b/net-dns/pdns-ldap-backend/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ <description>Primary Maintainer</description>
+</maintainer>
+</pkgmetadata>
diff --git a/net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild b/net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild
new file mode 100644
index 000000000000..01fa5dbf8b7b
--- /dev/null
+++ b/net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Fork of the official but unmaintained LDAP backend"
+HOMEPAGE="http://repo.or.cz/w/pdns-ldap-backend.git http://sequanux.org/cgi-bin/mailman/listinfo/pdns-ldap-backend"
+SRC_URI="http://sequanux.org/dl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="sasl"
+
+DEPEND=">=net-dns/pdns-3.2[-ldap]
+ net-nds/openldap[sasl=]
+ virtual/krb5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-pdns="${EPREFIX}/usr/include" \
+ --libdir=/usr/$(get_libdir)/powerdns
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README USAGE* src/dns.ldif"
+ default
+ prune_libtool_files --all
+ insinto /etc/openldap/schema
+ doins schema/*
+}